Bug 1347456 - EWS 2.1.1 DR1: RHEL Tomcat 6/7 libtcnative should look for ./libcrypto or we must set LD_LIBRARY_PATH
Summary: EWS 2.1.1 DR1: RHEL Tomcat 6/7 libtcnative should look for ./libcrypto or we ...
Keywords:
Status: CLOSED DUPLICATE of bug 1347455
Alias: None
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: tomcat6, tomcat7, openssl
Version: 2.1.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: DR02
: 2.1.1
Assignee: Coty Sutherland
QA Contact: Michal Karm Babacek
URL:
Whiteboard:
Depends On: 1347455
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-16 23:18 UTC by Michal Karm Babacek
Modified: 2016-06-20 16:18 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1347455
Environment:
Last Closed: 2016-06-20 16:18:09 UTC
Type: Bug


Attachments (Terms of Use)

Description Michal Karm Babacek 2016-06-16 23:18:42 UTC
This is a follow up on BZ #1347455.

> java.lang.UnsatisfiedLinkError: /tmp/mod_cluster-eapx/jboss-ews-2.1/tomcat7/lib/libtcnative-1.so: /lib64/libcrypto.so.10: version `OPENSSL_1.0.2' not found (required by /tmp/mod_cluster-eapx/jboss-ews-2.1/tomcat7/lib/libtcnative-1.so)

Even if we provide the binaries, I think we still need to make the dynamic linker to look for libcrypto either in directory relative to libtcnative or we would have to have a postinstall setting LD_LIBRARY_PATH in catalina.sh and probably for daemon, startup and jsvc scripts too.

Essentially, we deal with exactly the same issue as on Solaris. 



+++ This bug was initially created as a clone of Bug #1347455 +++

SSIA, we have to have copies not only in httpd zips but also in tomcat zips,
because users might not use both at the same time - they might unzip just tomcats.

Comment 1 Coty Sutherland 2016-06-20 16:18:09 UTC
I did a quick test of the fix posted for rhzb#1347455 and (as expected) it resolves this issue. I'll close this one as a duplicate.

*** This bug has been marked as a duplicate of bug 1347455 ***


Note You need to log in before you can comment on or make changes to this bug.