Bug 134763 - ps(1) cannot output multi-byte characters properly.
ps(1) cannot output multi-byte characters properly.
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: procps (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
:
: 134780 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-06 02:21 EDT by L3support
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-18 03:53:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
procps-3.2.3 utf8 patch for your tests.. (2.79 KB, patch)
2004-10-07 08:32 EDT, Karel Zak
no flags Details | Diff
v2 of UTF8 procps patch (4.92 KB, patch)
2004-10-13 03:17 EDT, Karel Zak
no flags Details | Diff

  None (edit)
Description L3support 2004-10-06 02:21:40 EDT
Description of problem:
ps(1) cannot output a process name or a path including mulitibyte
characters. 

Version-Release number of selected component (if applicable):
procps-3.2.3-3

How reproducible:
always

Steps to Reproduce:
1. Specify Japanese character 'てすと' as an application name.
   # cc test.c -o てすと
2. # ./てすと &
3. # ps -a 

-----
// test.c
main(){ 
    sleep(60);
}
-----

Actual results:
# ps
  PID TTY          TIME CMD
 3286 pts/3    00:00:00 bash
 3412 pts/3    00:00:00 ??
 3413 pts/3    00:00:00 ps

Expected results:
[root@plat-tiger4b tmp]# ps
  PID TTY          TIME CMD
 3286 pts/3    00:00:00 bash
 3412 pts/3    00:00:00 てすと
 3413 pts/3    00:00:00 ps

Additional info:
Comment 1 Jay Turner 2004-10-06 05:26:40 EDT
*** Bug 134780 has been marked as a duplicate of this bug. ***
Comment 2 Jay Turner 2004-10-06 06:25:48 EDT
There's a corresponding RHEL3 bug as well as #112518.
Comment 4 Karel Zak 2004-10-07 08:32:24 EDT
Created attachment 104887 [details]
procps-3.2.3 utf8 patch for your tests..
Comment 5 L3support 2004-10-08 05:07:40 EDT
Thank you so much. It works well. Will this patch be applyed soon?

Regards,
Comment 6 Karel Zak 2004-10-13 03:16:20 EDT
This patch is not right :-) I have new and better version and I just
test it together with upstream maintainer.
Comment 7 Karel Zak 2004-10-13 03:17:50 EDT
Created attachment 105113 [details]
v2 of UTF8 procps patch
Comment 9 L3support 2004-10-19 20:29:00 EDT
Thanks for the revised patch. 
ps(1) can output UTF8 multibyte characters. But some commands such as
w(1), pmap(1) and top(1) abnormally end with segmentation fault.
Comment 10 Karel Zak 2004-10-20 02:23:20 EDT
Sorry. It's already fixed in latest patch version. I forgot release at
bugzilla. The patch will available in next procps upstream and RH
release -- now I need one or two days for tests. Thanks for your interest.
Comment 11 Karel Zak 2004-11-05 02:52:35 EST
The beta version with UTF8 support:

http://people.redhat.com/kzak/procps/beta/
Comment 12 Karel Zak 2004-11-18 03:53:35 EST
The UTF-8 support for "ps" is done in new version (3.2.4) of procps,
but this version is not included in RHEL4 (we will see it probably in
next enterprice version). The stable patch is available now when RHEL4
is in the beta state and it's too late.

The first distribution with this feature will FC4.

Note You need to log in before you can comment on or make changes to this bug.