Bug 134771 - Syntax error in /etc/X11/xinit/Xclients, Xsession doesn't start
Syntax error in /etc/X11/xinit/Xclients, Xsession doesn't start
Status: CLOSED DUPLICATE of bug 134673
Product: Fedora
Classification: Fedora
Component: xinitrc (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-06 03:48 EDT by Pavel Lisy
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Lisy 2004-10-06 03:48:48 EDT
Description of problem:

There is syntax error in script /etc/X11/xinit/Xclients


Version-Release number of selected component (if applicable):
xinitrc-4.0.7-1

How reproducible:
Always

Steps to Reproduce:
1. Try login in gdm
2.
3.
  
Actual results:
Xsesion of user started

Expected results:
Error with message: Unexpected eng of file in /etc/X11/xinit/Xclients
and return to gdm

Additional info:
Wrong code:

if [ -f /etc/sysconfig/desktop ]; then
    . /etc/sysconfig/desktop
    if [ "$DESKTOP" = "GNOME" ]; then
        PREFERRED=gnome-session
    elif [ "$DESKTOP" = "KDE" ]; then
        PREFERRED=startkde
fi


Correct code:
if [ -f /etc/sysconfig/desktop ]; then
    . /etc/sysconfig/desktop
    if [ "$DESKTOP" = "GNOME" ]; then
        PREFERRED=gnome-session
    elif [ "$DESKTOP" = "KDE" ]; then
        PREFERRED=startkde
    fi
fi
Comment 1 Mike A. Harris 2004-10-06 08:36:15 EDT

*** This bug has been marked as a duplicate of 134673 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.