Bug 1347755 - JobExecutionException is thrown in SessionDataContainer.cleanExpiredUsersSessions
Summary: JobExecutionException is thrown in SessionDataContainer.cleanExpiredUsersSess...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: AAA
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ovirt-4.0.1
: ---
Assignee: Martin Perina
QA Contact: Gonza
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-17 14:35 UTC by Martin Perina
Modified: 2016-06-17 21:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-17 21:34:08 UTC
oVirt Team: Infra
mperina: ovirt-4.0.z?
mperina: planning_ack?
mperina: devel_ack+
mperina: testing_ack?


Attachments (Terms of Use)

Description Martin Perina 2016-06-17 14:35:46 UTC
Description of problem:

JobExecutionException is thrown in SessionDataContainer.cleanExpiredUsersSessions because we iterate through the existing sessions using iterator, but we are removing expired sessions directly and not using iterator for that.

Version-Release number of selected component (if applicable):

4.0.0

How reproducible:

100%

Steps to Reproduce:
1. Login to webadmin
2. Wait until session is expires
3. Cca 1 minute later SessionDataContainer.cleanExpiredUsersSessions is executed and in server.log JobExecutionException can be seen

Actual results:


Expected results:


Additional info:

Comment 1 Martin Perina 2016-06-17 21:34:08 UTC
My mistake, removal works fine even by direct call due to use of ConcurrentHashMap


Note You need to log in before you can comment on or make changes to this bug.