Bug 134780 - ps(1) cannot output multi-byte characters properly.
ps(1) cannot output multi-byte characters properly.
Status: CLOSED DUPLICATE of bug 134763
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: procps (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-06 05:22 EDT by L3support
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description L3support 2004-10-06 05:22:50 EDT
Description of problem:
ps(1) cannot output a process name or a path including mulitibyte
characters. 

Version-Release number of selected component (if applicable):
procps-3.2.3-3

How reproducible:
always

Steps to Reproduce:
1. Specify Japanese character 'てすと' as an application name.
   # cc test.c -o てすと
2. # ./てすと &
3. # ps -a 

-----
// test.c
main(){ 
    sleep(60);
}
-----

Actual results:
# ps
  PID TTY          TIME CMD
 3286 pts/3    00:00:00 bash
 3412 pts/3    00:00:00 ??
 3413 pts/3    00:00:00 ps

Expected results:
[root@plat-tiger4b tmp]# ps
  PID TTY          TIME CMD
 3286 pts/3    00:00:00 bash
 3412 pts/3    00:00:00 てすと
 3413 pts/3    00:00:00 ps

Additional info:
Comment 1 Jay Turner 2004-10-06 05:26:28 EDT

*** This bug has been marked as a duplicate of 134763 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.