Bug 134787 - bonding + dhcp does not work
bonding + dhcp does not work
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: initscripts (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks: 132991
  Show dependency treegraph
 
Reported: 2004-10-06 06:09 EDT by Nicolas Mailhot
Modified: 2014-03-16 22:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 11:21:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ifup-dhcp-bonding.patch (339 bytes, patch)
2004-11-09 09:54 EST, Bastien Nocera
no flags Details | Diff

  None (edit)
Description Nicolas Mailhot 2004-10-06 06:09:33 EDT
When I try bonding+dhcp on an up-to-date RHES3 system (tg3 cards), the
system fails to setup the interface. bonding+static interface info works.

(dhcp+bonding also failed on RHES2.1, but not in the same way)

modules.conf
=============
alias bond0 bonding
options bond0 miimon=100 downdelay=400 updelay=1000 mode=active-backup
alias eth0 tg3
alias eth1 tg3

ifcfg-bond0
===========
DEVICE=bond0
ONBOOT=yes
USERCTL=no
BOOTPROTO='dhcp'

ifcfg-eth0/1
============
# Broadcom Corporation|NetXtreme BCM5704 Gigabit Ethernet
DEVICE=eth0
USERCTL=no
ONBOOT=yes
MASTER=bond0
SLAVE=yes
BOOTPROTO=none

Bonding+dhcp failure
====================
Oct  6 05:27:44 charybde2 sysctl: kernel.sysrq = 0
Oct  6 05:27:44 charybde2 sysctl: kernel.core_uses_pid = 1
Oct  6 05:27:44 charybde2 sysctl: kernel.shmmax = 2147483648
Oct  6 05:27:44 charybde2 sysctl: kernel.shmmni = 4096
Oct  6 05:27:44 charybde2 sysctl: kernel.shmall = 2097152
Oct  6 05:27:44 charybde2 sysctl: kernel.sem = 512 32000 512 128
Oct  6 05:27:44 charybde2 sysctl: fs.file-max = 65536
Oct  6 05:27:44 charybde2 sysctl: fs.aio-max-size = 2147483647
Oct  6 05:27:44 charybde2 network: Configuration des paramètres réseau
: succeeded
Oct  6 05:27:44 charybde2 network: Activation de l'interface loopback
: succeeded
Oct  6 05:27:44 charybde2 kernel: bond0: enslaving eth0 as a backup
interface with a down link.
Oct  6 05:27:44 charybde2 ifup: Conversion de eth0 en esclave de bond0
Oct  6 05:27:44 charybde2 kernel: bond0: enslaving eth1 as a backup
interface with a down link.
Oct  6 05:27:44 charybde2 ifup: Conversion de eth1 en esclave de bond0
Oct  6 05:27:44 charybde2 ifup:
Oct  6 05:27:44 charybde2 ifup: Définition des informations IP pour bond0.
Oct  6 05:27:45 charybde2 kernel: tg3: eth0: Link is up at 100 Mbps,
full duplex.
Oct  6 05:27:45 charybde2 kernel: tg3: eth0: Flow control is on for TX
and on for RX.
Oct  6 05:27:45 charybde2 kernel: bond0: link status up for interface
eth0, enabling it in 1000 ms.
Oct  6 05:27:46 charybde2 kernel: tg3: eth1: Link is up at 100 Mbps,
full duplex.
Oct  6 05:27:46 charybde2 kernel: tg3: eth1: Flow control is on for TX
and on for RX.
Oct  6 05:27:46 charybde2 kernel: bond0: link status up for interface
eth1, enabling it in 1000 ms.
Oct  6 05:27:46 charybde2 kernel: bond0: link status definitely up for
interface eth0.
Oct  6 05:27:46 charybde2 kernel: bond0: making interface eth0 the new
active one.
Oct  6 05:27:47 charybde2 kernel: bond0: link status definitely up for
interface eth1.
Oct  6 05:27:48 charybde2 dhclient: DHCPREQUEST on bond0 to
255.255.255.255 port 67
Oct  6 05:27:48 charybde2 dhclient: DHCPACK from 192.168.1.8
Oct  6 05:27:48 charybde2 dhclient: bound to 192.168.1.23 -- renewal
in 3306 seconds.
Oct  6 05:27:48 charybde2 ifup:  terminé.
Oct  6 05:27:48 charybde2 ifup: SIOCBONDRELEASE: cannot detach DEVICE
from bond0. errno=No such device.
Oct  6 05:27:48 charybde2 kernel: bond0: link status down for idle
interface eth0, disabling it in 400 ms.
Oct  6 05:27:48 charybde2 ifup: Conversion de eth0 en esclave de bond0
Oct  6 05:27:48 charybde2 ifup: SIOCBONDRELEASE: cannot detach DEVICE
from bond0. errno=No such device.
Oct  6 05:27:48 charybde2 ifup: Conversion de eth1 en esclave de bond0
Oct  6 05:27:48 charybde2 kernel: bond0: link status down for idle
interface eth1, disabling it in 400 ms.
Oct  6 05:27:48 charybde2 network: Activation de l'interface bond0 :
succeeded
Oct  6 05:27:48 charybde2 kernel: bond0: link status definitely down
for interface eth0, disabling it<6>bond0: now running without any
active interface !

Bonding+static success
======================
Oct  6 05:32:49 charybde2 sysctl: kernel.sysrq = 0
Oct  6 05:32:49 charybde2 sysctl: kernel.core_uses_pid = 1
Oct  6 05:32:49 charybde2 sysctl: kernel.shmmax = 2147483648
Oct  6 05:32:49 charybde2 sysctl: kernel.shmmni = 4096
Oct  6 05:32:49 charybde2 sysctl: kernel.shmall = 2097152
Oct  6 05:32:49 charybde2 sysctl: kernel.sem = 512 32000 512 128
Oct  6 05:32:49 charybde2 sysctl: fs.file-max = 65536
Oct  6 05:32:49 charybde2 sysctl: fs.aio-max-size = 2147483647
Oct  6 05:32:49 charybde2 network: Configuration des paramètres réseau
: succeeded
Oct  6 05:32:49 charybde2 network: Activation de l'interface loopback
: succeeded
Oct  6 05:32:51 charybde2 ifup: Conversion de eth0 en esclave de bond0
Oct  6 05:32:51 charybde2 kernel: bond0: enslaving eth0 as a backup
interface with a down link.
Oct  6 05:32:51 charybde2 ifup: Conversion de eth1 en esclave de bond0
Oct  6 05:32:51 charybde2 kernel: bond0: enslaving eth1 as a backup
interface with a down link.
Oct  6 05:32:51 charybde2 network: Activation de l'interface bond0 :
succeeded
Oct  6 05:32:52 charybde2 kernel: tg3: eth0: Link is up at 100 Mbps,
full duplex.
Oct  6 05:32:52 charybde2 kernel: tg3: eth0: Flow control is on for TX
and on for RX.
Oct  6 05:32:53 charybde2 kernel: bond0: link status up for interface
eth0, enabling it in 1000 ms.
Oct  6 05:32:53 charybde2 kernel: tg3: eth1: Link is up at 100 Mbps,
full duplex.
Oct  6 05:32:53 charybde2 kernel: tg3: eth1: Flow control is on for TX
and on for RX.
Oct  6 05:32:53 charybde2 kernel: bond0: link status up for interface
eth1, enabling it in 1000 ms.
Oct  6 05:32:54 charybde2 kernel: bond0: link status definitely up for
interface eth0.
Oct  6 05:32:54 charybde2 kernel: bond0: making interface eth0 the new
active one.
Oct  6 05:32:54 charybde2 kernel: bond0: link status definitely up for
interface eth1.
Comment 1 Bill Nottingham 2004-10-06 12:28:52 EDT
Which specific initscripts version?
Comment 2 Nicolas Mailhot 2004-10-06 13:14:39 EDT
latest RHES3 release I think, I'll get you the exact version tomorrow
morning (french time)
Comment 3 Nicolas Mailhot 2004-10-07 04:18:43 EDT
[root@charybde root]# rpm -q initscripts
initscripts-7.31.16.EL-1
Comment 4 Daniel Wharton 2004-10-30 22:26:53 EDT
I am seeing the same issue.  I am using the same driver as well (tg3)
with a Broadcom BCM5704S.  I see in a previous bugzilla dealing with
dhcp+bonding, it was fixed with initscripts.  Could this be another
initscripts problem?
Comment 5 Daniel Wharton 2004-10-30 22:37:19 EDT
If I use this method to bring them up:

/sbin/ifconfig bond0 up
/sbin/ifenslave bond0 eth0
/sbin/ifenslave bond0 eth1

it works fine

----

ok... if I downgrade initscripts to 

initscripts-7.31.13.EL-1.i386.rpm

it works...

looks like someone will not be allowing up2date on initscrips... shame
on RH

daniel
Comment 6 Bastien Nocera 2004-11-09 09:53:12 EST
It's because there's a typo in the ifenslave. Patch attached below.
Comment 7 Bastien Nocera 2004-11-09 09:54:18 EST
Created attachment 106334 [details]
ifup-dhcp-bonding.patch
Comment 8 Nicolas Mailhot 2004-11-09 10:42:27 EST
Nice catch - I can confirm the fix works - the script complains eth0
still use the same mac, but sets up the dhcp bonded link all right

Is there any hope for an official errata ?
Comment 9 Bill Nottingham 2004-11-09 12:23:12 EST
Will be in 7.31.20.EL-1, whenever that is released.
Comment 10 Bill Nottingham 2004-11-17 18:17:12 EST
Looks like 7.31.20.EL-1 is scheduled for U5.
Comment 11 Nicolas Mailhot 2004-11-19 07:08:54 EST
Ok, thanks, I guess we'll just distribute a patched rpm in the meanwhile
Comment 15 John Flanagan 2005-04-28 11:21:47 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-117.html
Comment 16 Tim Powers 2005-05-18 11:35:59 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-123.html

Note You need to log in before you can comment on or make changes to this bug.