Bug 134792 - autofs in FC2 does not see edits in yp maps, just additions
autofs in FC2 does not see edits in yp maps, just additions
Status: CLOSED DUPLICATE of bug 128979
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
2
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-06 08:55 EDT by Paul Raines
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Raines 2004-10-06 08:55:36 EDT
Description of problem:

If an entry in a yp map for autofs is changed, the autofs daemon
refuses to every see it till complete killed and restarted 
(efficitvely requiring a reboot of the system).  Entries added to
the map are seen.   Doing a 'service autofs reload' or sending it
the HUP signal has no effect.  Looks like contrary to the man page,
autofs daemon simply ignores all signals and does nothing.

Version-Release number of selected component (if applicable):

autofs-4.1.2-2

How reproducible:

Every time on an FC2 box.  Not a problem on RH9 or RH7.3

Steps to Reproduce:

Have an entry such as

foo   host1:/foo

in an YP automount map and start autofs on test host.  Then 
mount 'foo' through automount, then wait for it to unmount, then
take host1 down, then bring up host2 (maybe same as host1 but you
changed its IP) and change the YP map to be

foo   host2:/foo

then try to mount foo again on the test host.  It fails.  Doing a
reload of autofs on the test host doesn't help.  Only rebooting
the test host to complete restart autofs works.

  
Actual results:

autofs fails to recognize edited map entry.  Also does not behave
as per man page for signals sent.

Expected results:

Should see new map entry and be able to mount volume according to
change.  Should do what the man pages says when signals are sent.

Additional info:
Comment 1 Jeffrey Moyer 2004-10-14 20:11:14 EDT

*** This bug has been marked as a duplicate of 128979 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:06:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.