Bug 1347962 - nvml 1.0-2.el7 FTBFS
Summary: nvml 1.0-2.el7 FTBFS
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: nvml
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Krzysztof Czurylo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-19 10:29 UTC by Tuomo Soini
Modified: 2016-07-20 21:47 UTC (History)
1 user (show)

Fixed In Version: nvml-1.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-20 21:47:30 UTC
Type: Bug


Attachments (Terms of Use)
mock build.log (171.94 KB, text/plain)
2016-06-19 10:31 UTC, Tuomo Soini
no flags Details
mock root.log (153.99 KB, text/plain)
2016-06-19 10:32 UTC, Tuomo Soini
no flags Details
mock build.log (645.88 KB, text/plain)
2016-06-30 07:58 UTC, Tuomo Soini
no flags Details
mock root.log (147.73 KB, text/plain)
2016-06-30 07:59 UTC, Tuomo Soini
no flags Details

Description Tuomo Soini 2016-06-19 10:29:35 UTC
Description of problem:

I tried to rebuild nvml-1.0-2.el7.src.rpm from epel7 testing.

Note: I fixed epel-7-x86_64.cfg which by default doesn't install epel-rpm-macros package.

It failed to build with epel-7-x86_64 config, Also it did fail if I enabled testing repo in epel-7-x86_64 config so question was not about missing dependency.

Comment 1 Tuomo Soini 2016-06-19 10:31:08 UTC
Created attachment 1169506 [details]
mock build.log

Comment 2 Tuomo Soini 2016-06-19 10:32:08 UTC
Created attachment 1169507 [details]
mock root.log

Comment 3 Tuomo Soini 2016-06-29 22:47:14 UTC
You pushed this to stable while I reported FTBFS?

Comment 4 Tuomo Soini 2016-06-29 22:48:46 UTC
Sorry, I didn't explain FTBFS stands for Fail to build from source.

Comment 5 Krzysztof Czurylo 2016-06-30 07:46:59 UTC
Sorry for that. For some reason I overlooked this bugzilla. My fault.

1) What do you mean by "build from source"? How does it differ from builds on koji, which are working fine?
2) For me it looks like a problem in man or col utility. So, perhaps the bug should (also) be filed for one of those.

Comment 6 Tuomo Soini 2016-06-30 07:56:20 UTC
Ok. I found one issue in epel buildsys-build group which I address directly to epel.

Issue is you can't just rebuild nvml package at all because package always fails tests.

Modification needed for now is to edit /etc/mock/epel-7-x86_64.cfg and modify line:

config_opts['chroot_setup_cmd'] = 'install util-linux @buildsys-build'

I added util-linux here because there is a bug in buildsys-build group in epel7 and it doesn't include util-linux.

Then the build process: you can do that on fedora or rhel7 or centos7 machine with mock installed and yourself added to mock group:

mock -r epel-7-x86_64 --rebuild /path/to/nvml-1.0-2.el7.src.rpm

I add resulted logs.

Comment 7 Tuomo Soini 2016-06-30 07:58:23 UTC
Created attachment 1174380 [details]
mock build.log

Comment 8 Tuomo Soini 2016-06-30 07:59:02 UTC
Created attachment 1174381 [details]
mock root.log

Comment 9 Krzysztof Czurylo 2016-06-30 12:10:09 UTC
Thanks for update!

As for the last issue, it's already fixed on master:
https://github.com/pmem/nvml/pull/782

The fix is available in NVML 1.1, so there are two options:
- add this patch to nvml spec and update to 1.0-3.el7;
- update package to version 1.1-1 (which is already in Fedora 24/25).

However, the problem is that I pushed NVML to EPEL by mistake. Since nvml is targeting main RHEL distro, it should not be shipped to EPEL, I believe.
So, instead of updating the package, perhaps it should be removed from EPEL completely.

Comment 10 Tuomo Soini 2016-06-30 12:33:29 UTC
I don't have need for nvml package on epel7 so I have no problem with that.

Comment 11 Tuomo Soini 2016-07-02 21:35:38 UTC
You really need that same patch for rhel7 too...

https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-cbcf16b270 is affected by this same bug.

Comment 12 Fedora Update System 2016-07-04 22:21:18 UTC
nvml-1.1-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-a1d87a575b

Comment 13 Fedora Update System 2016-07-05 14:48:07 UTC
nvml-1.1-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-a1d87a575b

Comment 14 Fedora Update System 2016-07-20 21:47:27 UTC
nvml-1.1-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.