Bug 134902 - new_fax script not called when notify (email address) is configured
new_fax script not called when notify (email address) is configured
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mgetty (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-06 22:53 EDT by Travers Carter
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-21 11:21:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mgetty log with debug set to 5 in mgetty.config (5.71 KB, text/plain)
2004-10-12 20:46 EDT, Travers Carter
no flags Details

  None (edit)
Description Travers Carter 2004-10-06 22:53:13 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, 
like Gecko) 
 
Description of problem: 
/etc/mgetty+sendfax/new_fax is not called after a fax is recieved 
unless 
 
a) No notification email address is configured ('notify' on a single 
line with no parameters in /etc/mgetty+sendfax/mgetty.config) 
 
- or - 
 
b) The notification email fails (eg rejected immediately by the local 
mail server) 
 
 
 
Version-Release number of selected component (if applicable): 
1.1.30-6.1 
 
How reproducible: 
Always 
 
Actual Results:  new_fax was only called after the notification email 
failed, or after disabling email notifications in mgetty.config 
 
Expected Results:  new_fax should be called (if present) 
independantly of the notification email setting or it's failure. 
 
Additional info: 
 
The system's default MTA is postfix not sendmail. 
 
mgetty is run from /etc/inittab with the following line 
f0:2345:respawn:/sbin/mgetty -n 1 -F /dev/ttyS0 
but running it manually from a shell with the same arguments doesn't 
make any difference.
Comment 1 Jason Vas Dias 2004-10-07 11:33:55 EDT
Please try the latest version of mgetty (1.1.31-2), which is in the 
process of being pushed to FC2 updates, but which meanwhile 
can be downloaded from:
     http://people.redhat.com/~jvdias/mgetty/FC2
If the problem persists, please append details to this bug report -
thanks.
Comment 2 Travers Carter 2004-10-12 20:46:38 EDT
Created attachment 105104 [details]
mgetty log with debug set to 5 in mgetty.config

I upgraded the mgetty & mgetty-sendfax packages (the only mgetty packages
installed on the system) to 1.1.31-2 from the supplied URL and added an email
address to the notify line in /etc/mgetty/mgetty.config

When a fax was recieved an email notification was sent but the new_fax script
was not called.

/etc/mgetty/new_fax is a symlink to a shell script in /usr/local/sbin if that
makes a difference.

I have attached the relevent bits of /var/log/mgetty.log.ttyS0 (with debug set
to 5 in mgetty.config)
Comment 3 Jason Vas Dias 2004-10-13 11:12:55 EDT
 OK, I'll fix this in the next release - many thanks for your feedback.
Comment 4 Jason Vas Dias 2005-02-21 11:21:43 EST
On closer inspection it appears that the default action upon receiving
a fax is to run the /etc/mgetty+sendfax/new_fax script .  
You change this default action by specifying the 'notify' option 
in the config file; new_fax is then not called unless this notify
option command fails. I believe this is correct and intended operation.

You can easily specify a new_fax script that sends mails as well. See
/usr/share/doc/mgetty-1.1.31/samples/new_fax.{mail,mime1,mime3,mime4} .

Note You need to log in before you can comment on or make changes to this bug.