Bug 134926 - eject does not eject a cd
eject does not eject a cd
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: eject (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-07 06:23 EDT by Joachim Backes
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-02 10:23:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mount;mount /mnt/cdrom;eject (3.58 KB, text/plain)
2004-11-03 01:37 EST, Joachim Backes
no flags Details

  None (edit)
Description Joachim Backes 2004-10-07 06:23:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
ejecting a mounted cdrom fails:

eject
umount: /dev/cdrom: not mounted
eject: unmount of `/dev/cdrom' failed

But when unounting the CD by hand, then eject ejects the CD

root@sunny [root]: umount /mnt/cdrom
root@sunny [root]: eject
root@sunny [root]:


Version-Release number of selected component (if applicable):
eject-2.0.13-5

How reproducible:
Sometimes

Steps to Reproduce:
1.mount CDROM
2.command: eject


    

Actual Results:  eject is rejected

Expected Results:  cd is ejected

Additional info:
Comment 1 Ngo Than 2004-10-07 06:54:17 EDT
it's strange. it's not reproduceable on my machine! i tried as root with 

mount /dev/cdrom /mnt/cdrom
eject

it always works for me. it's helpfull if you could give exactly
instructions how to reproduce this problem. Thanks
Comment 2 Ngo Than 2004-11-02 10:23:21 EST
sorry, i cannot reproduce this problem on my machine. It works for me
with a IDE CDROM. please reopen it if you have exactly instructions
how to reproduce this problem. Thanks
Comment 3 Joachim Backes 2004-11-03 01:37:52 EST
Created attachment 106111 [details]
mount;mount /mnt/cdrom;eject

I scripted the failed eject as you will see in the attached file xxxxx.

Note You need to log in before you can comment on or make changes to this bug.