Bug 134995 - clumanager init script should have default case, error non-zero
Summary: clumanager init script should have default case, error non-zero
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: clumanager   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-07 20:01 UTC by Derek Anderson
Modified: 2009-04-16 20:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-28 20:31:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes problem as well as upgrade problem when no /etc/cluster.xml is present (697 bytes, patch)
2004-12-16 18:41 UTC, Lon Hohberger
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:047 high SHIPPED_LIVE clumanager and redhat-config-cluster bug fix update 2005-05-25 04:00:00 UTC

Description Derek Anderson 2004-10-07 20:01:37 UTC
Description of problem:
Just a nitpick enhancement.

It seems to be standard practice in init scripts to have a default in
the case selection in case some knob (like me) types 'service
clumanager shutdown', gets a success error code and assumes his
cluster has stopped.

  *)
        echo $"Usage: $0 {start|stop|status|restart}"
        exit 1

Version-Release number of selected component (if applicable):
1.2.16

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Lon Hohberger 2004-10-08 14:00:15 UTC
You're right, it should.

Comment 2 Lon Hohberger 2004-12-16 18:41:44 UTC
Created attachment 108734 [details]
Fixes problem as well as upgrade problem when no /etc/cluster.xml is present

Comment 4 Derek Anderson 2005-02-28 20:31:41 UTC
Verified against clumanager-1.2.25-2.  Scheduled for release RHEL3-U5.

Comment 5 Jay Turner 2005-05-25 16:41:00 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-047.html



Note You need to log in before you can comment on or make changes to this bug.