Bug 135007 - Specfile: Buildrequires for platforms with scanner support broken
Specfile: Buildrequires for platforms with scanner support broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdegraphics (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-07 18:18 EDT by Frank Schmitt
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-08 05:25:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Frank Schmitt 2004-10-07 18:18:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001
Firefox/0.10.1

Description of problem:
The current specfile reads
%ifarch %{scanner_archs}
BuildRequires: sane-backends-devel >= 1.0.3-10
BuildRequires: gphoto2-devel
%endif
but scanner_archs isn't defined, only no_scanner_archs. Because of
this,  the two build requirements aren't checked on platforms
supporting scanners. Further on, when we build with scanner support,
libexif-devel is needed but it isn't mentioned in the specfile.
I think the following would work:
%ifnarch %{no_scanner_archs}
BuildRequires: sane-backends-devel >= 1.0.3-10
BuildRequires: gphoto2-devel
BuildRequires: libexif-devel
%endif

Version-Release number of selected component (if applicable):
kdegraphics-3.3.0-2

How reproducible:
Always

Steps to Reproduce:
1. Try to recompile the kdegraphics SRPM on a computer with arch =
i386 where one of sane-backends-devel, gphoto2-devel or libexif-devel
are missing.
2. See how rpmbuild fails.

Additional info:
Comment 1 Ngo Than 2004-10-08 05:25:23 EDT
It's now fixed in 3.3.0-3. Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.