Bug 135012 (IT#59580) - MTU and MRU can not be longer a fix value in adsl-connect
Summary: MTU and MRU can not be longer a fix value in adsl-connect
Status: CLOSED ERRATA
Alias: IT#59580
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rp-pppoe   
(Show other bugs)
Version: 3.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Jay Turner
URL:
Whiteboard: RHEL3U7NAK
Keywords:
Depends On:
Blocks: 187539
TreeView+ depends on / blocked
 
Reported: 2004-10-08 00:30 UTC by Uwe Beck
Modified: 2015-01-08 00:08 UTC (History)
4 users (show)

Fixed In Version: RHBA-2006-0334
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-03 18:55:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0334 normal SHIPPED_LIVE rp-pppoe bug fix update 2006-07-19 19:18:00 UTC

Description Uwe Beck 2004-10-08 00:30:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.4.3)
Gecko/20040924

Description of problem:
In RHEL3 the MTU and MRU value for pppd can not be longer a fix value
in the /sbin/adsl-connect script.

Some providers use other MTU value since a short time. Users need the
possibility to change actual MTU=1492 to the value the provider use.

Here are a current message from "German T-Com" for "Businnes T-DSL"
users if they want use a fix ip-address, T-DSL is a synonym for ADSL:

#####################################################################
Mitteilung  vom  01.10.2004  /  15:09

Neu: Feste IP-Adresse bei T-DSL Business 1000 - 2000 - 3000!

Seit dem 01.10.2004 koennen Sie die Vorteile einer festen IP-Adresse
auch bei den asymmetrischen T-DSL Business Anschluessen nutzen.

Wichtig: Sollten Sie fuer Ihren T-DSL Business Zugang eine sogenannte
"MTU-Size" fest eingestellt haben (z.B. auf 1492), so muss dieser Wert
bei Nutzung der festen IP-Adresse auf 1456 angepasst oder alternativ
die feste Voreinstellung der MTU-Size entfernt werden.
#####################################################################

Developer in Stuttgart already knows this message.

First step:
- variables for MTU and MRU in /sbin/adsl-connect script
- if there are no MTU and MRU parameters in the config file ifcfg-ppp0
the /sbin/adsl-connect script should set the value 1492

--> Than Ngo has already implement this in the RHEL4_BETA1
rp-pppoe-3.5-18.i386.rpm --> script can use without changes in RHEL3




Version-Release number of selected component (if applicable):
rp-pppoe-3.5-4.1

How reproducible:
Always

Steps to Reproduce:
1. configure ADSL for a provider which use other MTU than 1492
2.
3.
    

Actual Results:  change for MTU and MRU must take in
/sbin/adsl-connect script

Expected Results:  MTU and MRU are parameters in ifcfg-ppp0

Additional info:

redhat-config-network should allow to set MTU and MRU other the
default value 1492

This is a bug and also an enhancement that can easy fixed (three lines
in /sbin/adsl-connect script).

Comment 1 Ngo Than 2004-10-08 09:14:47 UTC
it's already fixed for RHEL4Beta2 and current fc3test3.

Comment 2 Uwe Beck 2004-10-08 13:02:01 UTC
RHEL3_U4 should also provide the new /sbin/adsl-connect sript.

Comment 3 Uwe Beck 2004-10-14 22:34:32 UTC
rp-pppoe-3.5-18.i386.rpm does not work.
There is a mistake in the /sbin/adsl-connect script. The pppd can not
start.

Oct 15 00:15:33 adslub adsl-connect: ADSL connection lost; attempting
re-connection.
Oct 15 00:15:38 adslub pppd[4233]: invalid numeric parameter 'mru' for
mtu option

Resolution in /sbin/adsl-connect script:

MTU and MRU are strings here.
[ -z "MTU" ] && MTU="1492"
[ -z "MRU" ] && MRU="1492"

MTR and MRU must be variables.

[ -z "$MTU" ] && MTU="1492"
[ -z "$MRU" ] && MRU="1492"

Now it works for me.


Comment 4 Uwe Beck 2004-10-15 06:16:51 UTC
After my last additional comments I see the new version
rp-pppoe-3.5-21.i386.rpm.
Default values for MTU and MRU are set correct now.

I also test Dial on Demand. If you start the ASDL interface the
/sbin/adsl-connect script create the ppp0 interface as a
point-to-point interface with the same local and remote ip addresses
by default. This is not correct and the result of a change in the
script. The local and remote ip address can also configure in
ifcfg-ppp0, good. If this is not done in ifcfg-ppp0 the default values
for local and remote ip adresses should be different, I think so.


Comment 5 Ngo Than 2004-10-15 12:27:52 UTC
it's typo bug here and is now fixed in 3.5-22. Thanks for your report.

Comment 6 Steve Conklin 2005-01-04 16:21:56 UTC
 The customer has opened a ticket requesting that this bug be fixed in
U5 and RHEL4.


Comment 21 Daniel Riek 2006-03-14 04:29:39 UTC
The impact of this is high enough to carry forward the request to the next Update. 

Moving to the next Update, clearing all ACKs.

Comment 27 Red Hat Bugzilla 2006-05-03 18:55:42 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0334.html



Note You need to log in before you can comment on or make changes to this bug.