Bug 135059 - Neon does not apply memory limits to external data from the network
Summary: Neon does not apply memory limits to external data from the network
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: neon   
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-08 12:34 UTC by Alan Cox
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-25 16:17:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alan Cox 2004-10-08 12:34:36 UTC
Description of problem:
Neon does not apply a sanity limit to propfind responses.

Neon should apply a limit in order to prevent memory exhaustion by a
hostile DAV server.

Comment 1 Joe Orton 2004-10-13 20:14:09 UTC
Yes, thanks, known issue.  I'm working towards fixing this for neon
0.25.x.

Comment 2 Joe Orton 2004-10-25 16:17:18 UTC
This is done for neon 0.25, backporting to 0.24.x is hard because it
requires a couple of API changes to do properly, so it will have to wait.


Note You need to log in before you can comment on or make changes to this bug.