Bug 1350638 - [RADOS]:[UPGRADE]: Apparent data loss after upgrading from 1.3.2 to 2.0 using "setuser match path" config
Summary: [RADOS]:[UPGRADE]: Apparent data loss after upgrading from 1.3.2 to 2.0 using...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS
Version: 2.0
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: rc
: 2.0
Assignee: Samuel Just
QA Contact: shylesh
URL:
Whiteboard:
: 1355958 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-28 02:57 UTC by shylesh
Modified: 2017-07-30 15:14 UTC (History)
8 users (show)

Fixed In Version: RHEL: ceph-10.2.2-9.el7cp Ubuntu: ceph_10.2.2-7redhat1xenial
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:43:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1339870 unspecified CLOSED /usr/bin/rados depends on libradosstriper.so.1 2020-10-14 00:28:05 UTC
Red Hat Product Errata RHBA-2016:1755 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Internal Links: 1339870

Comment 2 Samuel Just 2016-06-28 15:41:00 UTC
We think this was due to me messing up the patch removing libradosstriper for https://bugzilla.redhat.com/show_bug.cgi?id=1339870 (there is no corresponding upstream bug).  The next build should have it fixed.

Comment 5 Vasu Kulkarni 2016-06-28 16:38:30 UTC
The upgrade process doesn't look right to me, a restart of process is not sufficient after upgrade there could be old osd process still running, also is this a reason to run everything as root/root instead of ceph/ceph?

the steps mentioned here are accurate: bz 1347395 which is yet to go into docs.

Comment 6 shylesh 2016-06-28 16:46:21 UTC
(In reply to Vasu Kulkarni from comment #5)
> The upgrade process doesn't look right to me, a restart of process is not
> sufficient after upgrade there could be old osd process still running, also
> is this a reason to run everything as root/root instead of ceph/ceph?
> 
> the steps mentioned here are accurate: bz 1347395 which is yet to go into
> docs.

@Vasu,

Upgrade is actually done by tejas, I think he followed the proper docs for upgrade. It might be my mistake in the description.

Comment 7 Vasu Kulkarni 2016-06-28 16:49:45 UTC
Thanks shylesh, the ll still shows root/root for /var/lib/ceph in your earlier comment

drwxr-xr-x. 3 root root 218 Jun 27 10:48 ceph-3

Comment 8 shylesh 2016-06-28 16:52:51 UTC
(In reply to Vasu Kulkarni from comment #7)
> Thanks shylesh, the ll still shows root/root for /var/lib/ceph in your
> earlier comment
> 
> drwxr-xr-x. 3 root root 218 Jun 27 10:48 ceph-3

@Vasu,

Yes that's the use case for "setuser match path = /var/lib/ceph/$type/$cluster-$id". Existing root owned dirs will remain as root and processes also runs as root. Any newly added osds after upgrade will run as ceph.

Comment 12 shylesh 2016-06-30 16:46:48 UTC
Verifid on RHEL7.2 ceph-common-10.2.2-9.el7cp.x86_64 and now rados tool works fine. Hence marking it as verified

Comment 13 Samuel Just 2016-07-13 14:36:08 UTC
*** Bug 1355958 has been marked as a duplicate of this bug. ***

Comment 15 errata-xmlrpc 2016-08-23 19:43:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.