Bug 1351023 - black screen when booting kernel 4.5.7 [NEEDINFO]
Summary: black screen when booting kernel 4.5.7
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-29 05:14 UTC by David Bolding
Modified: 2017-08-08 15:09 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-08 15:09:06 UTC
Type: Bug
bugzilla77: needinfo? (kernel-maint)


Attachments (Terms of Use)
boot log (85.46 KB, text/plain)
2016-06-29 05:26 UTC, David Bolding
no flags Details

Description David Bolding 2016-06-29 05:14:32 UTC
Description of problem:
I have freshly installed Fedora 24 over an Ubuntu installation.  Kernel 4.5.7 was installed by an update.  When booting Kernel 4.5.7, I get a black screen on boot; I assume the kernel is hung, since the caps-lock key does nothing.  The previous kernel, 4.5.5, boots fine.

Version-Release number of selected component (if applicable):
Kernel 4.5.7

How reproducible:
Every time I've tried.

Steps to Reproduce:
1. install kernel 4.5.7 from updates
2. select kernel on boot

Actual results:
black screen, no response from key-presses

Expected results:
System starting normally.

Additional info:
This is a hybrid GPU system (with an NVidia GPU no less), that might be part of the problem.


I don't know what kind of diagnostic information is useful, and guidance would be appreciated.

Output of LSPCI:
00:00.0 Host bridge: Intel Corporation Skylake Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07)
00:04.0 Signal processing controller: Intel Corporation Skylake Processor Thermal Subsystem (rev 08)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Device 9d10 (rev f1)
00:1c.5 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #6 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
01:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 940M] (rev a2)
02:00.0 Network controller: Intel Corporation Wireless 7265 (rev 59)

Comment 1 David Bolding 2016-06-29 05:26:12 UTC
Created attachment 1173649 [details]
boot log

output of journalctl -k -b -1

Comment 2 David Bolding 2016-06-29 05:35:03 UTC
(In reply to David Bolding from comment #1)
> Created attachment 1173649 [details]
> boot log
> 
> output of journalctl -k -b -1

oops, I think that's for the last successful boot, since it says it's for Kernel 4.5.5 (and the time is wrong).

Comment 3 David Bolding 2016-07-05 19:37:28 UTC
I got the 4.6 kernel from an update; the problem appears intermittently with 4.6; sometimes it boots OK, and sometimes it doesn't.  I haven't found any pattern yet between when it will boot OK and when it won't.

4.5.5 kernel is still booting fine.

Comment 4 David Bolding 2016-07-05 20:18:30 UTC
As per the Common kernel problems wiki page, I tried removing quiet and rhgb from the boot options, and I still see a black screen.  I tried booting without quiet or rhgb, and with boot_delay=1000; this still produces a black screen.

The system behaves slightly differently with boot_delay=1000 specified.  Without it, I have to hold the power button down for 5 seconds to restart the system.  /With/ boot_delay=1000, as soon as I press the power button, the system powers off (instead of restarting).  I don't know if that information is useful at all.

If I haven't mentioned it before, this system is EFI (and it starts in EFI mode).

Comment 5 David Bolding 2016-07-05 20:33:12 UTC
I'm sorry to keep spamming this, but, the system will boot with acpi=off as a boot parameter.  I tried booting the 4.6.3 kernel installed from updates with just that change, and the system came up.  (It didn't shut down correctly, but I'm assuming that's because it couldn't power down the system with ACPI off.)

Comment 6 Francois Cartegnie 2016-07-17 19:13:33 UTC
Same here. Asus UX305UA no longer boots after upgrade to 4.5.7-300.fc24.
previously booting 4.5.7-200.fc23.

Just black screen and cpu high.
No hybrid graphics.
acpi=off solves it

Comment 7 Francois Cartegnie 2016-07-18 13:25:48 UTC
seems video related.
i915.modeset=0 always boots

Comment 8 Francois Cartegnie 2016-07-27 14:06:09 UTC
Seems bug 1353103 duplicate.

Comment 9 Fedora End Of Life 2017-07-25 21:24:37 UTC
This message is a reminder that Fedora 24 is nearing its end of life.
Approximately 2 (two) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 24. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '24'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 24 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 10 Fedora End Of Life 2017-08-08 15:09:06 UTC
Fedora 24 changed to end-of-life (EOL) status on 2017-08-08. Fedora 24 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.