Bug 135158 - modprobe of firewire modules results in stack trace in /var/log/messages
Summary: modprobe of firewire modules results in stack trace in /var/log/messages
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 2
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-09 13:52 UTC by Thomas Walker
Modified: 2015-01-04 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-18 16:40:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas Walker 2004-10-09 13:52:37 UTC
Description of problem:
Loading firewire modules (ohci1394, ieee1394, sbp2) results in the
following stack trace in /var/log/messages and failed detection of the
device

Oct  9 09:46:10 thwalker kernel: ohci1394: $Rev: 1223 $ Ben Collins
<bcollins@debian.org>
Oct  9 09:46:10 thwalker kernel: ACPI: PCI interrupt 0000:00:0a.0[A]
-> GSI 18 (level, low) -> IRQ 169
Oct  9 09:46:10 thwalker kernel: ohci1394: fw-host0: Unexpected PCI
resource length of 1000!
Oct  9 09:46:10 thwalker kernel: ohci1394: fw-host0: OHCI-1394 1.1
(PCI): IRQ=[169]  MMIO=[e2000000-e20007ff]  Max Packet=[2048]
Oct  9 09:46:11 thwalker kernel: Badness in ohci_hw_csr_reg at
drivers/ieee1394/ohci1394.c:3154
Oct  9 09:46:11 thwalker kernel:
Oct  9 09:46:11 thwalker kernel: Call Trace:<IRQ>
<ffffffffa07ab9c1>{:ohci1394:ohci_hw_csr_reg+124}
<ffffffffa00d5ece>{:ieee1394:host_reset+106}
Oct  9 09:46:11 thwalker kernel:       
<ffffffffa00d5a49>{:ieee1394:highlevel_host_reset+47}
Oct  9 09:46:11 thwalker kernel:       
<ffffffffa07aa896>{:ohci1394:ohci_irq_handler+2691}
Oct  9 09:46:11 thwalker kernel:       
<ffffffff80114440>{handle_IRQ_event+43} <ffffffff801148bb>{do_IRQ+402}
Oct  9 09:46:11 thwalker kernel:       
<ffffffff801120f3>{ret_from_intr+0}  <EOI>
<ffffffffa07a7439>{:ohci1394:set_phy_reg+534}
Oct  9 09:46:11 thwalker kernel:       
<ffffffffa07a824a>{:ohci1394:ohci_devctl+212}
<ffffffffa00d4964>{:ieee1394:delayed_reset_bus+0}
Oct  9 09:46:11 thwalker kernel:       
<ffffffffa00d2120>{:ieee1394:hpsb_reset_bus+24}
<ffffffff8014d3c8>{worker_thread+634}
Oct  9 09:46:11 thwalker kernel:       
<ffffffff80133e9e>{default_wake_function+0}
<ffffffff80133e9e>{default_wake_function+0}
Oct  9 09:46:11 thwalker kernel:       
<ffffffff8014d14e>{worker_thread+0} <ffffffff8014d14e>{worker_thread+0}
Oct  9 09:46:11 thwalker kernel:       
<ffffffff8015305e>{kthread+119} <ffffffff801125d7>{child_rip+8}
Oct  9 09:46:11 thwalker kernel:       
<ffffffff8014d14e>{worker_thread+0} <ffffffff80152fe7>{kthread+0}
Oct  9 09:46:11 thwalker kernel:        <ffffffff801125cf>{child_rip+0}
Oct  9 09:46:12 thwalker ieee1394.agent[25599]: ... no drivers for
IEEE1394 product 0x/0x/0x
Oct  9 09:46:12 thwalker ieee1394.agent[25585]: ... no drivers for
IEEE1394 product 0x/0x/0x

Devices in question:
20GB Ipod (3rd gen)
00:0a.0 FireWire (IEEE 1394): NEC Corporation IEEE 1394 Host
Controllerkernel-2.6.8-1.521 (rev 01) (from lspci)

Version-Release number of selected component (if applicable):
kernel-2.6.8-1.521

How reproducible:
modprobe ohci1394 ieee1394 sbp2
check the logs


Actual results:
stack trace in messages
device not recognized

Expected results:
device will be recognized

Additional info:

Comment 1 Thomas Walker 2005-02-18 16:40:54 UTC
not getting any attention and seems to be fixed in fc3 so I'll close
it and remove it from your list.


Note You need to log in before you can comment on or make changes to this bug.