This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 13517 - /usr/include/asm symlinks are incorrectly created
/usr/include/asm symlinks are incorrectly created
Status: CLOSED DUPLICATE of bug 13291
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
sparc64 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-06 06:40 EDT by Phil Mayers
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-12 03:44:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Mayers 2000-07-06 06:40:36 EDT
The 2.2.14-5.0 kernel-headers spec file has this:

But in the spec file for the 2.2.16-3, around line 691:

mkdir asm
/usr/src/linux-%{kversion}/include/asm-sparc/BuildASM /usr/include/asm

This should be:

mkdir asm
/usr/src/linux-%{kversion}/include/asm-sparc/BuildASM /usr/include

The /usr/include/asm directory will *NOT* be built, and various packages 
cannot build (openssh 2+, etc.) without the appropriate headers present. 
This is a pretty poor show really guys! :o)

Machine is:

uname -a

Linux hostname 2.2.16-3 #1 Mon Jun 19 20:41:27 EDT 2000 sparc64 unknown
Comment 1 Phil Mayers 2000-07-06 06:46:29 EDT
Oops - the first lines should read:

The 2.2.14-5.0 kernel-headers had this working.

But in the spec file for the 2.2.16-3... <and so on>

Comment 2 hebert 2000-07-11 14:00:43 EDT
also, 
/boot/kernel.h is not created 
only /boot/kernel.h-2.2.16 is
so I had to copy it under the name of /boot/kernel.h
Comment 3 roger.bivand 2000-07-12 03:44:09 EDT
Please also see #13711 and #13291 and comments there
Comment 4 Alan Cox 2000-08-22 15:18:01 EDT

*** This bug has been marked as a duplicate of 13291 ***

Note You need to log in before you can comment on or make changes to this bug.