Bug 135210 - gawk-3.1.4 has problems
Summary: gawk-3.1.4 has problems
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gawk   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Karel Zak
QA Contact:
URL:
Whiteboard:
Keywords:
: 135211 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-10 15:41 UTC by Jeff Johnson
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-15 11:15:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Script to reproduce the extraction. (734 bytes, text/plain)
2004-10-10 15:43 UTC, Jeff Johnson
no flags Details
Correct output, generated by gawk-3.1.3-9 (5.13 KB, text/plain)
2004-10-10 15:44 UTC, Jeff Johnson
no flags Details

Description Jeff Johnson 2004-10-10 15:41:47 UTC
Description of problem:
rpm uses gawk to build rpmdb/tagtbl.c from
strings in lib/rpmlib.h for a long time now.

That extraction fails with gawk-3.1.4, works with gawk-3.1.3.

Comment 1 Jeff Johnson 2004-10-10 15:43:10 UTC
Created attachment 104986 [details]
Script to reproduce the extraction.

Comment 2 Jeff Johnson 2004-10-10 15:44:07 UTC
Created attachment 104987 [details]
Correct output, generated by gawk-3.1.3-9

Comment 3 Bill Nottingham 2004-10-11 15:14:11 UTC
*** Bug 135211 has been marked as a duplicate of this bug. ***

Comment 5 Karel Zak 2004-11-15 11:15:52 UTC
Fixed in gawk-3.1.4-4 [FC-4].


Note You need to log in before you can comment on or make changes to this bug.