Bug 1352210 - texlive-bibexport provides dangling link /usr/bin/bibexport.sh
Summary: texlive-bibexport provides dangling link /usr/bin/bibexport.sh
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: texlive
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-02 13:11 UTC by schlaffi
Modified: 2016-10-28 00:40 UTC (History)
3 users (show)

Fixed In Version: texlive-2016-17.20160520.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-28 00:40:36 UTC
Type: Bug


Attachments (Terms of Use)

Description schlaffi 2016-07-02 13:11:12 UTC
Description of problem:

When installing texlive-bibexport there will be a dangling link

/usr/bin/bibexport.sh -> /usr/share/texlive/texmf-dist/scripts/bibexport.sh

which should not eb

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1. dnf --setopt=clean_requirements_on_remove=0 remove texlive-bibexport
2. find -H /usr/bin/ -xtype l (returns nothing)
3. dnf install texlive-bibexport
3. find -H /usr/bin/ -xtype l

Actual results:

The find command yields

/usr/bin/bibexport.sh

Expected results:

nothing

Additional info:

Since texlive-bibexport-bin provides /usr/bin/bibexport, which is a link to the existing /usr/share/texlive/texmf-dist/scripts/bibexport/bibexport.sh, I guess bibexport.sh should not be linked into /usr/bin by texlive-bibexport.

Versions

texlive-bibexport-bin-svn16219.0-24.20150728_r37987.fc24.1.noarch
texlive-bibexport-svn29349.3.01-24.fc24.1.noarch

Comment 1 Fedora Update System 2016-10-05 20:30:37 UTC
perl-BibTeX-Parser-0.69-1.fc25, perl-LaTeX-ToUnicode-0.04-1.fc25, texlive-2016-5.20160520.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-50a2bc7997

Comment 2 Fedora Update System 2016-10-06 20:59:37 UTC
perl-BibTeX-Parser-0.69-1.fc25, perl-LaTeX-ToUnicode-0.04-1.fc25, texlive-2016-6.20160520.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-50a2bc7997

Comment 3 schlaffi 2016-10-09 07:22:52 UTC
The bug was reported against fc24, so I don't get the update from testing, it seems. Admittedly it is a very minor bug.

Comment 4 Fedora Update System 2016-10-09 12:30:40 UTC
perl-BibTeX-Parser-0.69-1.fc25, perl-LaTeX-ToUnicode-0.04-1.fc25, texlive-2016-7.20160520.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-50a2bc7997

Comment 5 Fedora Update System 2016-10-26 20:33:38 UTC
perl-BibTeX-Parser-0.69-1.fc25, perl-LaTeX-ToUnicode-0.04-1.fc25, texlive-2016-17.20160520.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-50a2bc7997

Comment 6 Fedora Update System 2016-10-28 00:40:36 UTC
perl-BibTeX-Parser-0.69-1.fc25, perl-LaTeX-ToUnicode-0.04-1.fc25, texlive-2016-17.20160520.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.