This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 135236 - FC array logical volume not correctly detected
FC array logical volume not correctly detected
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-11 02:53 EDT by Dan Horak
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-21 08:58:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dan Horak 2004-10-11 02:53:03 EDT
Description of problem:
My hardware
- server Compaq Proliant 6000 with 4x PII/400, 3GB RAM
- two fibre channel cards Emulex LP-8000
- fibre channel array Compaq RA-4x00 with dual controllers

The following is output of dmesg after booting the kernel - 
specificly the part of detecting SCSI devices attached to FC cards. 
As you can see, the array is detected as "array controller" and not 
as "logical volume". So there are no scsi disks available even when 
the array contains one logical volume.

Emulex LightPulse Fibre Channel SCSI driver 8.0.10
lpfc 0000:04:03.0: 0:1303 Link Up Event x1 received Data: x1 x2 x0 x0
scsi2 : Emulex LightPulse LP8000 1 Gigabit PCI Fibre Channel Adapter 
on PCI bus 04 device 18 irq 11
scsi: unknown device type 12
  Vendor: COMPAQ    Model: ARRAY CONTROLLER  Rev: 2.60
  Type:   RAID                               ANSI SCSI revision: 00
lpfc 0000:00:01.0: 1:1303 Link Up Event x1 received Data: x1 x2 x0 x0
scsi3 : Emulex LightPulse LP8000 1 Gigabit PCI Fibre Channel Adapter 
on PCI bus 00 device 08 irq 11
scsi: unknown device type 12
  Vendor: COMPAQ    Model: ARRAY CONTROLLER  Rev: 2.60
  Type:   RAID                               ANSI SCSI revision: 00


Here is an output from booting the previous RHEL 3 with kernel 2.4.21-
20.ELsmp

Emulex LightPulse FC SCSI/IP: 2.01g    Osgt: 1.08
PCI: Enabling device 00:01.0 (0156 -> 0157)
lpfc0:1303:LKe:Link Up Event x1 received Data: x1 x2 x0 x0
PCI: Enabling device 04:03.0 (0156 -> 0157)
lpfc1:1303:LKe:Link Up Event x1 received Data: x1 x2 x0 x0
scsi3 : HBA: Emulex LightPulse LP8000 on PCI bus 00 device 08 irq 11
scsi4 : HBA: Emulex LightPulse LP8000 on PCI bus 04 device 18 irq 11
blk: queue f666ee18, I/O limit 4294967295Mb (mask 0xffffffffffffffff)
  Vendor: COMPAQ    Model: LOGICAL VOLUME    Rev: 2.60
  Type:   Direct-Access                      ANSI SCSI revision: 00
blk: queue f6661c18, I/O limit 4294967295Mb (mask 0xffffffffffffffff)
Attached scsi disk sda at scsi3, channel 0, id 0, lun 0
SCSI device sda: 177711030 512-byte hdwr sectors (90988 MB)
 sda: sda1
blk: queue f6677418, I/O limit 4294967295Mb (mask 0xffffffffffffffff)
  Vendor: COMPAQ    Model: LOGICAL VOLUME    Rev: 2.60
  Type:   Direct-Access                      ANSI SCSI revision: 00
blk: queue f6677218, I/O limit 4294967295Mb (mask 0xffffffffffffffff)
Attached scsi disk sdb at scsi4, channel 0, id 0, lun 0



Version-Release number of selected component (if applicable):
kernel-2.6.8-1.528.2.10smp

How reproducible:
Always

Steps to Reproduce:
1. boot
2. watch detecting SCSI devices
  
Actual results:
Logical volume not detected

Expected results:
Logical volume is detected

PS: multipathing with FC array controllers in active/standby mode is 
not working, but another story ...
Comment 3 Matt Jamison 2004-10-19 17:43:57 EDT
the problem is solved by using a 66mhz 64-bit pci compaq controller
with the tachyon chip.  specifically the part number is #161290-001
this card will work with the cpqfc driver in kernel-unsupported for
rhel3.  don't know what's going to happen w/ rhel4 and this driver.

this isn't a linux problem it's a compaq problem with their ra4x00
array.  the array isn't giving regular cards the proper information.
Comment 6 Tom Coughlan 2004-10-21 08:58:24 EDT
Closing this as a wontfix - get the required hardware update from
HP/Compaq.  

Note that although there is no kernel-unsupported rpm for RHEL 4, the
cpqfc should still be considered unsupported in RHEL 4.  I will
propose a release note to make this clear.


Comment 7 Dan Horak 2004-10-23 08:42:48 EDT
And will be there a kernel-unsupported package for RHEL 4? Or should 
I compile the kernel myself to get the cpqfc driver?
Comment 8 Tom Coughlan 2004-10-25 08:06:10 EDT
No, there will not be a kernel-unsupported package for RHEL 4. 

You can build cpqfc against the RHEL 4 kernel insmod it.

Note You need to log in before you can comment on or make changes to this bug.