Bug 135246 - hard-coded root home directory
hard-coded root home directory
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: up2date (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Fanny Augustin
:
: 137497 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-11 07:47 EDT by Bastien Nocera
Modified: 2007-11-30 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-14 11:50:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2004-10-11 07:47:39 EDT
Description of problem:
up2date doesn't find the GPG keys if root's $HOME isn't /root

Patch below from Jose Plans <jplans@redhat.com>:

--- up2date-AS-2.9.11/gpgUtils.py.jmp   Mon Oct 11 12:31:21 2004
+++ up2date-AS-2.9.11/gpgUtils.py       Mon Oct 11 12:31:09 2004
@@ -14,7 +14,7 @@
log = up2dateLog.initLog()

# directory to look for .gnupg/options, etc
-gpg_home_dir = "/root/.gnupg"
+gpg_home_dir = os.environ.get("HOME") + "/.gnupg"


def checkGPGInstallation():
Comment 1 Aleksey Nogin 2004-11-29 11:08:48 EST
*** Bug 137497 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.