Bug 135264 - rhn_register fails when using GUI
Summary: rhn_register fails when using GUI
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Max Spevack
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 143405
TreeView+ depends on / blocked
 
Reported: 2004-10-11 15:02 UTC by Max Spevack
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-28 18:46:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of the error (50.01 KB, image/png)
2004-10-11 15:02 UTC, Max Spevack
no flags Details

Description Max Spevack 2004-10-11 15:02:17 UTC
Description of problem:
If you try to register a system using rhn_register (the gui portion of
the component) several things go wrong:

1.  You get a series of glade warnings
2.  When you enter your username/password/etc on the required screen,
a dialog message comes back saying that you must enter a username
(which is already done).

I am pasting the warnings from the command line below, and attaching a
screenshot of the error to this bug.

[root@dhcp59-201 rhn]# rhn_register
 
(rhn_register:8933): libglade-WARNING **: unknown property
`focus_on_click' for class `GtkRadioButton'
 
(rhn_register:8933): libglade-WARNING **: unknown property
`focus_on_click' for class `GtkRadioButton'
 
(rhn_register:8933): libglade-WARNING **: unknown property
`focus_on_click' for class `GtkRadioButton'
 
(rhn_register:8933): libglade-WARNING **: unknown property
`focus_on_click' for class `GtkButton'
 
(rhn_register:8933): libglade-WARNING **: unknown property
`focus_on_click' for class `GtkButton'
 
(rhn_register:8933): libglade-WARNING **: unknown property
`focus_on_click' for class `GtkRadioButton'
 
(rhn_register:8933): libglade-WARNING **: unknown property
`focus_on_click' for class `GtkRadioButton'
 
(rhn_register:8933): libglade-WARNING **: unknown property
`focus_on_click' for class `GtkRadioButton'
 
(rhn_register:8933): libglade-WARNING **: unknown property
`focus_on_click' for class `GtkRadioButton'
 
(rhn_register:8933): libglade-WARNING **: unknown property
`focus_on_click' for class `GtkCheckButton'
 
(rhn_register:8933): libglade-WARNING **: unknown property
`focus_on_click' for class `GtkCheckButton'
 
(rhn_register:8933): libglade-WARNING **: unknown property
`focus_on_click' for class `GtkButton'
 
(rhn_register:8933): libglade-WARNING **: unknown property
`focus_on_click' for class `GtkButton'
 
(rhn_register:8933): libglade-WARNING **: unknown property
`focus_on_click' for class `GtkCheckButton'
 
(rhn_register:8933): libglade-WARNING **: unknown property
`focus_on_click' for class `GtkButton'
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 405, in
onLoginPagePrepare
    vbox.pack_start(loginWindowVbox, gtk.TRUE)
AttributeError: 'NoneType' object has no attribute 'pack_start'

Version-Release number of selected component (if applicable):
[root@dhcp59-201 rhn]# cat /etc/redhat-release
Red Hat Enterprise Linux AS release 3 (Taroon Update 3)

[root@dhcp59-201 rhn]# rpm -q up2date
up2date-4.2.41-1

How reproducible:
Reproduced on the local machine, and also with X forwarded over ssh to
another machine.

Registered on the command line without any problems.

Steps to Reproduce:
1.  See desc.
2.
3.
  
Actual results:
GUI registration fails.

Expected results:
GUI registration succeeds!

Additional info:

Comment 1 Max Spevack 2004-10-11 15:02:47 UTC
Created attachment 105013 [details]
screenshot of the error

Comment 2 Adrian Likins 2004-10-11 18:55:15 UTC
traceback is because I forgot to merge the gui.glade from
HEAD.

the warnings look to be something glade stuck in the
files for rhel4 that doesnt exist on rhel3, I'll
see if I can just remove it.

Comment 3 Adrian Likins 2004-10-11 20:01:18 UTC
4.2.43 should have the fixes

Comment 4 Max Spevack 2005-01-07 19:29:27 UTC
Moving this into rhn365hosted since it is an easy fix to verify.

Comment 5 Todd Warner 2005-01-21 17:57:42 UTC
mass move to ON_QA for the QA push two days ago.

Comment 6 Max Spevack 2005-01-24 21:17:47 UTC
Fixes verified in up2date-4.2.57-2.  PROD_READY


Note You need to log in before you can comment on or make changes to this bug.