Bug 135271 - redhat-rpm-config requires gcc 3.4
Summary: redhat-rpm-config requires gcc 3.4
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-rpm-config   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-11 15:50 UTC by David Juran
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-03 19:05:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Juran 2004-10-11 15:50:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
redhat-rpm-config-8.0.32-1 sets the optflags for i386 architechtures
to include -mtune=pentium4 but gcc lower then 3.4 (?) does not
understand this.

Version-Release number of selected component (if applicable):
redhat-rpm-config-8.0.32-1

How reproducible:
Always

Steps to Reproduce:
1. rpm -U  redhat-rpm-config-8.0.32-1.norach.rpm
2. rpmbuild --rebuild <just about anything>
cc1: error: invalid option `tune=pentium4'

    

Additional info:

Comment 1 Elliot Lee 2004-12-03 19:05:31 UTC
Added 'Conflicts: gcc < 3.4' for i386/i686/sparc

Thanks.

Comment 2 Barry K. Nathan 2004-12-03 22:59:31 UTC
That's arguably not a full solution -- if you try to recompile any RPM
package with compat-gcc (which is 3.3.x), then it still blows up
because it doesn't recognize the -mtune option.

But then again, maybe that problem isn't worth worrying about. (Or if
it is, then maybe the best way to fix/work around it would be to add
the -mtune option to compat-gcc.)


Note You need to log in before you can comment on or make changes to this bug.