Bug 13531 - System will not boot after kernel recompilation
Summary: System will not boot after kernel recompilation
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-06 14:09 UTC by harry.heinisch
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 00:14:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description harry.heinisch 2000-07-06 14:09:44 UTC
When the kernel is compiled, boot process stops right after MD driver load 
message.  This problem occurs regardless of system type (happens on Compaq 
ProLiant)

Steps to reproduce:
1. install RedHat 7.0 Beta2
2. compile the kernel
3. reboot the system
4. boot will stop after following message displays
   "md driver 0.90.0 MAX_MD_DEVS=256, MAX_REAL=12"

Comment 1 Bill Nottingham 2000-07-06 21:57:25 UTC
Yes. For now, don't compile the kernel with gcc-2.96.

Comment 2 John Cagle 2000-07-10 22:09:57 UTC
moved to beta3 since it still has GCC 2.96

Comment 3 Pekka Savola 2000-07-15 23:24:24 UTC
It seems that gcc is still used for kernel compilations, not kernelcc.  All
makefiles default to that, anyway.  Were the necessary changes to kernel sources
forgotten or is there some magic involved?

I tried getting around this by creating symlink from /usr/bin/gcc to
kernelcc, but somehow I think the new compiler was still being used; there
were a _lot_ off odd assembler warnings, for instance, and the system
wouldn't boot (did that remotely, no idea what broke).



Comment 4 Pekka Savola 2000-07-22 18:42:22 UTC
Still an issue in beta4.

Changing CC= (and HOSTCC=) to kgcc fixes this.



Comment 5 Michael K. Johnson 2000-08-01 21:40:16 UTC
The Pinstripe kernel srpm does this correctly now.

Comment 6 David Balažic 2001-02-07 17:25:39 UTC
kernel-source-2.2.16-22.i386 , as shipped with RHL 7.0
defaults again to (g)cc

I changed CC in makefile to kgcc , but make dep still
used gcc. Then I also changed HOSTCC in Makefile to kgcc,
then it was OK ( kgcc was used instead of gcc )


Note You need to log in before you can comment on or make changes to this bug.