Bug 135335 - uucp -C can't seem to access it's maintenance files
Summary: uucp -C can't seem to access it's maintenance files
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: uucp   
(Show other bugs)
Version: 3.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: Bill Huang
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-12 01:23 UTC by Ronald Cole
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-19 13:16:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of "strace uucp -C fi_uir.asc t17007!~/ (84.07 KB, text/plain)
2004-10-12 01:27 UTC, Ronald Cole
no flags Details

Description Ronald Cole 2004-10-12 01:23:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; 
SV1; .NET CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
$ uucp -C fi_uir.asc t17007!~/               
uucp: stat (/home/bms/tmp/rjc/fi_uir.asc): Permission denied

... which is a misleading error message since strace indicates that 
uucp is unable to open /var/spool/uucp/t17007/SEQF:

$ ls -l /var/spool/uucp/t17007/SEQF 
-rw-------    1 uucp     uucp            4 Oct 12 
10:01 /var/spool/uucp/t17007/SEQF

strace indicates that the reason it can't is because uucp seems to
not have the uucp uid at that point (it has mine instead).  But uucp 
is definitely suid:

$ ls -l /usr/bin/uucp
-r-sr-xr-x    1 uucp     uucp      1305254 Jan 25  2003 /usr/bin/uucp


Version-Release number of selected component (if applicable):
uucp-1.06.1-47

How reproducible:
Always

Steps to Reproduce:
1. try to "uucp -C" a file from your system to another system
2.
3.
    

Actual Results:  uucp failed with an error message and the copy 
didn't happen.

Expected Results:  uucp copies the file to the spool directory and 
then transfers the file to the remote system.

Additional info:

Comment 1 Ronald Cole 2004-10-12 01:27:43 UTC
Created attachment 105031 [details]
output of "strace uucp -C fi_uir.asc t17007!~/

notice the return values to the get*uid*() calls.  I can't tell how uucp lost
it's suid during program execution from this output, but it apparently did.

Comment 2 Peter Vrabec 2004-11-19 13:16:10 UTC
this helps me

- user must be in uucp group
- chmod g+w /var/spool/uucppublic



Note You need to log in before you can comment on or make changes to this bug.