Bug 135354 - [RHEL4] libbonoboui has bogus tamil translation
[RHEL4] libbonoboui has bogus tamil translation
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: libbonoboui (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
RHEL4U3NAK
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-11 23:49 EDT by Lawrence Lim
Modified: 2014-03-25 20:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-05 16:06:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Please find attached the latest copy of the po file. (14.08 KB, text/plain)
2004-10-12 00:14 EDT, Lawrence Lim
no flags Details
the po file generated from the libbonoboui package in RHEL4 (9.90 KB, text/x-gettext-translation)
2005-04-07 20:56 EDT, Lawrence Lim
no flags Details

  None (edit)
Description Lawrence Lim 2004-10-11 23:49:54 EDT
Description of problem:
Some of the tamil strings in ta.po is using the wrong encoding (TSCII
instead of UTF-8)

Version-Release number of selected component (if applicable):


How reproducible:
everytime

Steps to Reproduce:
1. Run application in LANG=ta_IN.UTF-8
  
Actual results:
some strings are broken because of the encoding

Expected results:
should display all of the strings in UTF-8

Additional info:
Comment 1 Lawrence Lim 2004-10-12 00:14:15 EDT
Created attachment 105050 [details]
Please find attached the latest copy of the po file.
Comment 2 Leon Ho 2004-11-01 01:21:22 EST
Just wanted to follow up if you have any timeframe on rebuilding the package for
RHEL4. It would be great to include the fixed tamil translation in because tamil
is one of our official supported languages. Thanks!
Comment 3 Ray Strode [halfline] 2005-04-07 15:52:41 EDT
Hi Lawrence and Leon.

Did this bug never get addressed or did the bug just not get closed?
Should i push out an erratum for RHEL4?  Did these fixes make their way upstream?
Comment 4 Lawrence Lim 2005-04-07 20:50:53 EDT
Hi Ray,
I converted the mo file for libbonoboui-2.0.mo from
libbonoboui-2.8.0.99cvs20040929-2 to po and noticed that there are some string
indeed were broken due to the encoding. This has been address in the po file
from Comment #1.

 
Comment 5 Lawrence Lim 2005-04-07 20:56:46 EDT
Created attachment 112841 [details]
the po file generated from the libbonoboui package in RHEL4
Comment 6 Ray Strode [halfline] 2005-04-08 10:00:18 EDT
Hi Lawrence,
Thanks for looking into this.  I'll see what I can do about getting this pushed
for U2.
Comment 7 Ray Strode [halfline] 2005-04-27 09:44:30 EDT
I commited this for fc4 today.  Hopefully it will make test3.
Comment 8 Ray Strode [halfline] 2005-05-04 17:42:53 EDT
I think this should be moved to RHEL4U2CanFix.  I believe that tamil is a RHEL-4
supported language, so we should ship as complete a translation as we can.  This
is a very low risk change, too--no functionality is going to break by replacing
a po file.  The only thing that could potentially happen is the tamil
translation getting more broken, but that's not likely.
Comment 11 dff 2005-07-29 16:16:54 EDT
This package was never assigned a QA slot for RHEL4 U2:
  http://intranet.corp.redhat.com/ic/intranet/U2Packages.html

QA capacity is already oversubscribed for RHEL4 U2.

Moving forward from RHEL4U2CanFix to RHEL4U3Proposed.
Comment 18 RHEL Product and Program Management 2006-09-05 15:57:36 EDT
The component this request has been filed against is not planned for inclusion
in the next update. The decision is based on weighting the priority and number
of requests for a component as well as the impact on the Red Hat Enterprise
Linux user-base: other components are considered having higher priority and the
number of changes we intend to include in update cycles is limited.
Comment 19 RHEL Product and Program Management 2006-09-05 16:06:53 EDT
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.