Bug 135373 - [RFE] Better printing options for PDFs
[RFE] Better printing options for PDFs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-12 06:04 EDT by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 13:56:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-10-12 06:04:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
I have a PDF file that I would like to print two pages per sheet.
There is no option to do this in ggv.

Acrobat Reader for Windows has this feature, but not their Linux version.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 Dan Williams 2004-11-17 13:25:10 EST
Mass reassign to Marco.
Comment 2 Alex Butcher 2004-11-25 10:39:13 EST
I use the following script to print 2up. It'll take input either from
standard input (i.e. a pipe) or using parameters.

#!/bin/sh
if [ $* ]; then
        echo args
        exec /usr/bin/psnup -pa4 -n 2 $1 | lpr
else
        echo noargs
        TMPFILE=`mktemp /tmp/lpr2up.XXXXXX` || exit 1
        cat >$TMPFILE
        a2ps -B $TMPFILE
        rm -f $TMPFILE
fi

Comment 3 Need Real Name 2005-03-08 10:17:12 EST
Changing to feature request for evince.
Comment 4 Need Real Name 2005-03-22 13:56:08 EST
Looks like evince can do this! Thanks to AB for the tip too.

Note You need to log in before you can comment on or make changes to this bug.