Bug 135386 - [PATCH] SII 3114 SATA support
[PATCH] SII 3114 SATA support
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-12 09:25 EDT by Bastien Nocera
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-19 10:51:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
kernel-2.4.21-15.EL-sii-3114.patch (1.55 KB, patch)
2004-10-12 09:27 EDT, Bastien Nocera
no flags Details | Diff

  None (edit)
Description Bastien Nocera 2004-10-12 09:25:30 EDT
In linux/drivers/ide/pci/siimage.c
We'd need the addition of the 3114 controller, to be able to use the
SII 3114 as a normal IDE device.
Patch attached below.

In linux/drivers/ide/pci/siimage.c, in init_hwif_siimage(), there
seems to be a bug:
       if(is_sata(hwif) == PCI_DEVICE_ID_SII_3112)
               hwif->busproc   = &siimage_busproc;
is_sata returns an int, which is the return value of pdev_is_data, and
pdev_is_sata only returns 1 or 0.

The machine is a Fujitsu-Siemens v810.
Comment 1 Bastien Nocera 2004-10-12 09:27:27 EDT
Created attachment 105057 [details]
kernel-2.4.21-15.EL-sii-3114.patch
Comment 2 John W. Linville 2004-10-19 10:05:02 EDT
The defect is reported against RHEL 2.1 but the patch is for a RHEL 3
kernel.  Which release is desired?
Comment 4 John W. Linville 2004-10-19 10:51:09 EDT
I ping'ed Jeff Garzik about this:

<linville> there already seems to be some overlap between sata_sil and
siimage w.r.t the Sil 3112 -- any thoughts on whether or not to
continue that for Sil 3114?
<jgarzik> vetoed :)
<jgarzik> use sata_sil
<jgarzik> siimage is unmaintained

Note You need to log in before you can comment on or make changes to this bug.