Bug 135414 - unescaped RPM macro places excessive garbage text into changelog
unescaped RPM macro places excessive garbage text into changelog
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-12 11:52 EDT by Moritz Barsnick
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-31 16:23:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Moritz Barsnick 2004-10-12 11:52:47 EDT
Description of problem:
In the SPEC file, there is an unescaped RPM macro, namely %configure. 
This is unfortunately expanded in the changelog (rpm -qp --changelog 
$file.rpm), and is a bit annoying.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. tail +`fgrep -n %changelog nfs-utils.spec | cut -d: -f1`  nfs-
utils.spec | fgrep %configure
 
Actual results:
- Build with %configure

Expected results:
- Build with %%configure

Additional info:
Comment 1 Moritz Barsnick 2005-11-01 04:49:59 EST
Oh, it seems the SPEC file has been changed in the meantime. Well, then I agree 
with this closure as "not a bug".  :-)  Thanks.
Comment 2 Moritz Barsnick 2005-11-01 05:01:48 EST
Darn! Damned browser! Who changed the component to 4Suite???

Please excuse the mishap. I'm changing it back to nfs-utils.

So, let me please withdraw my previous comment #1.

I still consider it a bug, as rpm -qp --changelog nfs-utils-1.0.7-19.FC5.src.rpm 
says:

[...]
* Mon Nov 18 2002 Stephen C. Tweedie <sct@redhat.com>

- Build with 
  CFLAGS="${CFLAGS:--O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -
fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=n
ocona}" ; export CFLAGS ; 
  CXXFLAGS="${CXXFLAGS:--O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions 
-fstack-protector --param=ssp-buffer-size=4 -m64 -mtu
ne=nocona}" ; export CXXFLAGS ; 
  FFLAGS="${FFLAGS:--O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -
fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=n
ocona}" ; export FFLAGS ; 
  for i in $(find . -name config.guess -o -name config.sub) ; do 
           [ -f /usr/lib/rpm/redhat/$(basename $i) ] && /bin/rm -f $i && /bin/cp 
-fv /usr/lib/rpm/redhat/$(basename $i) $i ; 
  done ; 
  ./configure --build=x86_64-redhat-linux --host=x86_64-redhat-linux \
        --target=x86_64-redhat-linux-gnu \
        --program-prefix= \
        --prefix=/usr \
        --exec-prefix=/usr \
        --bindir=/usr/bin \
        --sbindir=/usr/sbin \
        --sysconfdir=/etc \
        --datadir=/usr/share \
        --includedir=/usr/include \
        --libdir=/usr/lib64 \
        --libexecdir=/usr/libexec \
        --localstatedir=/var \
        --sharedstatedir=/usr/com \
        --mandir=/usr/share/man \
        --infodir=/usr/share/info
- Add nhfsgraph, nhfsnums and nhfsrun to the files list

* Mon Nov 11 2002 Stephen C. Tweedie <sct@redhat.com>
[...]

I don't really thinks that's intended. And as it sometimes changes, it becomes a 
dynamic changelog entry.

The intention must be:
[...]
* Mon Nov 18 2002 Stephen C. Tweedie <sct@redhat.com>

- Build with %configure
- Add nhfsgraph, nhfsnums and nhfsrun to the files list

* Mon Nov 11 2002 Stephen C. Tweedie <sct@redhat.com>
[...]

I will _not_ take the liberty to reopen this bug. Please, _you_ go ahead and 
judge...

Thanks,
Moritz
Comment 3 Steve Dickson 2005-11-01 06:18:31 EST
Ok I understand what you are saying... sorry for the confusion...
I've made the following changes to the spec file:
diff -r1.71 nfs-utils.spec
550c550
< - Build with %configure
---
> - Build with %%configure
and have check them into our CVS tree and will be
available on the next release of nfs-utils since I would
rather wait to bump the version number.  Unless you need
this fixed released sooner, just let me know...


Note You need to log in before you can comment on or make changes to this bug.