Bug 135447 - Can't use getpass() since it is obsolete
Can't use getpass() since it is obsolete
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: glibc (Show other bugs)
3.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-12 15:08 EDT by Linda Lee
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-13 08:03:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Linda Lee 2004-10-12 15:08:24 EDT
Description of problem:


Version-Release number of selected component (if applicable):

Red Hat AS 3 FCS

SYNOPSIS
       #include <unistd.h>

       char *getpass( const char * prompt );

DESCRIPTION
       This function is obsolete. Do not use it.

...


From the man page,  getpass() is an obsolete function and can NOT be
used, what is its equivalent function available on RHAS3?  If there is
no equivalent, can we still use getpass()?
Comment 1 Jakub Jelinek 2004-10-13 08:03:55 EDT
See http://www.opengroup.org/onlinepubs/007908799/xsh/getpass.html
This function was marked LEGACY since it provides no functionality which a user could not easily implement, and its name
is misleading.
It has been removed in XPG6.

Note You need to log in before you can comment on or make changes to this bug.