Bug 135490 - Problems with nv ethernet during install
Problems with nv ethernet during install
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alan Cox
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-12 20:25 EDT by Alan Cox
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 03:21:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2004-10-12 20:25:00 EDT
Description of problem:

Nv "forcedeth" ethernet is .loaded and found but anaconda denies it
exists.

How reproducible:
100%

Steps to Reproduce:
1. Boot FC3T3 boot.iso on box with nvidia ethernet
2. Select "NFS install"
  
Actual results:

"No blah device ..."

Expected results:

Install

Additional info:

The log shows that anaconda loads the forcedeth module. The kernel
sees both ethernet ports (eth0 and eth1). In addition if you install
using a plug in ethernet csrd (this works except for r8169,
via-velocity (kernel bugs) or natsemi (missing off boot.iso)) then it
does install via NFS.

Even odder post the base install it configures dhcp/static/etc for
*all three* ports.

Alan
Comment 1 Jeremy Katz 2004-10-12 21:28:36 EDT
Post-install, if you run 

python -c 'import kudzu; print kudzu.probe(kudzu.CLASS_NETWORK,
kudzu.BUS_UNSPEC, kudzu.PROBE_LOADED)'

what does it print?
Comment 2 Bill Nottingham 2004-10-12 21:50:37 EDT
If you've got a shell on tty2, what is the output of:

# python
>> import kudzu
>> kudzu.probe(kudzu.CLASS_NETWORK, kudzu.BUS_UNSPEC, 1<<31)
Comment 3 Alan Cox 2004-10-22 09:39:33 EDT
It hasn't got a shell t this point sorry - 
Comment 4 Paul Nasrat 2004-10-22 10:03:11 EDT
I've seen this with sungem on various Mac hardware.  Is there any
output on tty4/5 implying it's loaded (mac address appears with
sungem).  If it's the same issue - the module loads, but we endup
reprompting to choose a module but have removed it from the list.
Comment 6 Jay Hilliard 2005-05-02 16:57:48 EDT
(In reply to comment #4)
> I've seen this with sungem on various Mac hardware.  Is there any
> output on tty4/5 implying it's loaded (mac address appears with
> sungem).  If it's the same issue - the module loads, but we endup
> reprompting to choose a module but have removed it from the list.

Was there ever a resolution for this?
Comment 7 Dave Jones 2005-07-15 13:56:01 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 8 Dave Jones 2005-09-29 03:21:05 EDT
not that it helps fc3 at install time, but this was probably the 'network card
has a pci type of "bridge"' quirk that got fixed in an errata kernel.

fc4 should be fixed.

Note You need to log in before you can comment on or make changes to this bug.