Bug 135494 - X won't work with "driver nvidia", refuses to boot
X won't work with "driver nvidia", refuses to boot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-12 21:58 EDT by Jeremy LaCroix
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-13 06:22:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy LaCroix 2004-10-12 21:58:48 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:

Xorg has not been upgraded. The version of Xorg, is, I believe 6.8, 
it is the version that is on the FC3T3 ISO.

When I install the official nvidia driver, version 1.0-6111, it will 
install fine on kernel 2.6.8-1.541, but not at all on kernel 2.6.8-
1.603. If you attempt installation on .603, it will not find the 
kernel sourcecode.

If you install on .541 kernel, it will install perfectly, however, 
the nvidia kernel module won't load unless you do "modprobe nvidia" 
as root. After you load the module manually, it will work and 
Tuxracer will play at a fast refresh rate, but if you reboot, the 
system will hang at boot time under "configuring kernel parameters" 
and will stay there, after you see a flash which appears to mean that 
X failed to load.

This is not a problem with the nvidia installer, as the same version 
(1.0-6111) worked fine under FC2Stable.

So to summarize:
1. The nvidia driver will not install under kernel *.603, looks for 
sourcecode that is not there (Up2Date should install the source 
everytime you upgrade a kernel)

2. Under the stock kernel, *.541, the module will install fine, but 
will not load unless you manually modprobe nvidia

3. After editing xorg.conf to use the driver, and rebooting, the 
system will not boot, will freeze at kernel parameters.

Steps to Reproduce:
1.Install Nvidia driver version 1.0-6111
2.Edit xorg.conf for the new driver
3.xorg will not find the driver
4.modrpobe nvidia as root
5.Try 'startx' again, new driver will load
6.Reboot and the system will not finish booting
    
Actual Results:
The Nvidia kernel module didn't load until I "modprobed" it, and then 
the system wouldn't boot.

Expected Results:
The system should have allowed the nvidia driver to set the nvidia 
kernel module to autostart, without causing the system to not boot.

Additional Information:
This card works fine under windows. (There is no xorg on Windows)

Again, this is not a problem with nvidia, as the installer worked 
under FC2.
Comment 1 Andrew Farris 2004-10-13 02:47:21 EDT
That is a problem with the nVIDIA driver, a bug in the driver that is
caused by a recent kernel change... without the driver being updated.
 You can work around it, but the problem is not with Xorg or Fedora. 
The nVIDIA driver is once again behind in details with new development.

Try using the driver posted at the link below which is patched to deal
with the 2.6.8-1.603 kernel change (__VMALLOC_RESERVE is not exported,
unknown symbol).  It does work.

http://ngc891.blogdns.net/index.php?2004/09/21/3-patched-nvidia-drivers

This is not the optimal way to install the driver, see this suggestion
for an alternate method that does not blindly overwrite Mesa GL files.
 Email me or post to fedoraforum.org for additional help.

http://www.fedoraforum.org/forum/showpost.php?p=106977&postcount=76

This should be closed NOTABUG.  nVIDIA is responsible for making this
fix and will need to do so with the next release.
Comment 2 Andrew Farris 2004-10-13 02:47:58 EDT
Added me to CC.
Comment 3 Andrew Farris 2004-10-13 03:02:39 EDT
Forget to mention, the module autoloading failure is a documented bug
in udev being worked on, it may be fixed in rawhide.  If not, a simple
'modprobe nvidia' in /etc/rc.local does the trick.
Comment 4 Mike A. Harris 2004-10-13 06:22:43 EDT
Thanks for the report.  For users who are experiencing problems
installing, configuring, or using the unsupported 3rd party
proprietary "nvidia" video driver, Nvidia provides indirect
customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and
passes them on to Nvidia engineers for investigation.  Once
they've isolated a particular problem, it is often fixed in
a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums,
others who may have experienced the particular problem may
be able to assist.  If there is a real bug occuring, Nvidia
will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system
releases that they officially support.

While Red Hat does not support the proprietary nvidia driver,
users requiring technical support may also find the various
X.Org, XFree86, and Red Hat mailing lists helpful in finding
assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo

Setting status to "NOTABUG" (unsupported).

Note You need to log in before you can comment on or make changes to this bug.