Bug 135519 - [ttfonts-zh_CN] unable to print in the zh_CN locale when postscript is using CIDFnmap
[ttfonts-zh_CN] unable to print in the zh_CN locale when postscript is using ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ttfonts-zh_CN (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-13 05:07 EDT by Lawrence Lim
Modified: 2014-03-25 20:51 EDT (History)
3 users (show)

See Also:
Fixed In Version: ttfonts-zh_CN-2.14-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-20 23:00:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2004-10-13 05:07:38 EDT
Description of problem:
Tried to print a cn web site in the zh_CN locale. The resule was blank
for both physical prinout and ps file.

Version-Release number of selected component (if applicable):
- mozilla-1.7.3-11
- ttfonts-zh_CN-2.14-8
- fontconfig-2.2.3-4

How reproducible:
Always

Steps to Reproduce:
1.in gdm login as normal user with simplified chinese / gnome session
2.after run gnome, press alt-f2 to run dialog, enter mozilla
3.type URL: http://cn.yahoo.com
4.after the page is loaded, type Ctrl-P
5.select print to file
6.use ggv to open the ps file

  
Actual results:
Blank

Expected results:
The contents of the web page

Additional info:
Tried with both pango and without pango option
Comment 1 Leon Ho 2004-10-13 11:28:30 EDT
Look like it is only happening on Fedora Core but not RHEL. Looked
briefly if you do 'gs mozilla.ps' and there are resource missing
because of /usr/share/ghostscript/7.07/lib/CIDFnmap.zh_CN in
ttfonts-zh_CN consist: /MSungGBK-Light        
(/usr/share/fonts/zh_CN/TrueType/zysong.ttf)    ;

Removing this line for Fedora Core should be enough. It would be an
easy fix as branching out RHEL4, and devel for rawhide in cvs.devel
for different content of CIDFnmap.zh_CN and spec. Moving component to
ttfonts-zh_CN. Thanks.
Comment 2 Lawrence Lim 2004-10-14 00:39:42 EDT
Going through the steps again, there is improvement but unfortunately
the problem is not totally fix. This time, intead of displaying blank
page, ggv shows empty squares in place of chinese characters.

1.in gdm login as normal user with simplified chinese / gnome session
2.after run gnome, press alt-f2 to run dialog, enter mozilla
3.type URL: http://cn.yahoo.com
4.after the page is loaded, type Ctrl-P
5.select print to file
6.use ggv to open the ps file
Comment 3 Yu Shao 2004-10-14 00:45:58 EDT
If this is the case, the bug probably is still with mozilla, reassign
to mozilla for now.
Comment 4 Lawrence Lim 2004-10-18 04:03:14 EDT
Back to you Chris. :)
Comment 5 Leon Ho 2004-10-20 12:06:41 EDT
Problem was mozilla has MSungGBK-Light hardcoded. I don't think we can
fork mozilla into different conf for fc3 and rhel4... so we have to
change ttfonts-zh_CN to accommodate mozilla. Fixed in cvs and built.
sopwith is considering if it is staying in fc3-HEAD or fc3.
Comment 6 Leon Ho 2004-10-20 12:23:13 EDT
Current settings in dist-fc3-HEAD ATM:
/MSungGBK-Light (/usr/share/fonts/zh_CN/TrueType/gbsn00lp.ttf)  ;

Current settings in dist-4E:
/MSungGBK-Light (/usr/share/fonts/zh_CN/TrueType/zysong.ttf)    ;
Comment 7 Leon Ho 2004-10-20 13:11:48 EDT
2.14-10 is moved to dist-fc3 by sopwith. lawrence, please re-confirm.
Comment 8 Lawrence Lim 2004-10-20 23:00:19 EDT
Confirmed fixed. Tested ttfonts-zh_CN-2.14-10 with mozilla-1.7.3-13
and firefox-0.10.1-1.0PR1.10.



Thanks.

Note You need to log in before you can comment on or make changes to this bug.