Bug 135542 - secound Interface doesn't be activated "on the fly"
secound Interface doesn't be activated "on the fly"
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
s390x Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-13 08:01 EDT by Falko Pilz
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:16:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Falko Pilz 2004-10-13 08:01:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7)
Gecko/20040803 Firefox/0.9.3

Description of problem:
Hello,

all Linuxguest on our zVM has 2 QDIO (virtuell) interfaces one to over
an vswitch to the real LAN and on to a VM internal "guestlan".
So at the install both are present and anaconda does them show in
Network config dialog. After the reboot the secound interface with his
entry at /etc/chandev was lost so the guestlan wasn't abel to connect.
After apply the entry and calling 
echo "reset_conf\;read_conf" > /proc/chandev the device seems to be
initialized. but without reloading the qeth kernel module it doesn't
be able to aktivate. 
service network restart shows:
"qeth device eth1 does not seem to be present, delaying initialization."
After stoping eth0 from a x3270 and unloading qeth.o the "service
network start" does bring up the interface.

I doesn't know if it is an ifconfig or a kernel(module) failure,
because the driver should aktivate after reread chandev.conf.

Regards 

Falko

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot after new install
2.edit /etc/chandev.conf
3.echo "reset_conf\;read_conf" > /proc/chandev
4. service network restart
    

Actual Results:  ifup: qeth device eth1 does not seem to be present,
delaying initialization.
network: Bringing up interface eth1:  failed


Expected Results:  kernel: qeth: Trying to use card with devnos
0xA500/0xA501/0xA502
kernel: qeth: Device 0xA500/0xA501/0xA502 is an OSD Express card
(level: V447)
kernel: with link type Gigabit Eth (no portname needed by interface)
...
kernel: ip_tables: (C) 2000-2002 Netfilter core team
ifup: Cannot get driver information: Operation not supported
network: Bringing up interface eth1:  succeeded

Additional info:

It appears in both Arch's S390 and S390x.
Comment 2 RHEL Product and Program Management 2007-10-19 15:16:09 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.