Bug 135563 - NetorkManager kills network
NetorkManager kills network
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-13 11:22 EDT by Brian Millett
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-29 16:45:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brian Millett 2004-10-13 11:22:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041012
Firefox/0.10.1

Description of problem:
After starting the NetworkManager service, the system lost ethernet
connectivity.

Version-Release number of selected component (if applicable):
NetworkManager-0.2-4

How reproducible:
Always

Steps to Reproduce:
1. start NetworkManager service
2. run NetworkManagerInfo


Actual Results:  network is down

Expected Results:  should be up and functioning

Additional info:

trace of steps I took:

[bpm]$ sudo service NetworkManager start
Setting network parameters:                                [  OK  ]
Starting NetworkManager daemon:                            [  OK  ]
[bpm]$ NetworkManagerInfo
[bpm]$
** (NetworkManagerInfo:5708): WARNING **: Failed to send buffer

** (NetworkManagerInfo:5708): WARNING **: Failed to send buffer
nmwa_dbus_get_string(): org.freedesktop.NetworkManager.NoActiveNetwork
raised:
 The device is not associated with any networks at this time.


[bpm]$ ifconfig eth1
eth1      Link encap:Ethernet  HWaddr 00:02:6F:04:64:6A
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2536 errors:0 dropped:0 overruns:0 frame:0
          TX packets:662 errors:1 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:365199 (356.6 KiB)  TX bytes:106841 (104.3 KiB)
          Interrupt:11 Memory:e0500000-e0500fff


[bpm]$ sudo service network restart
Shutting down interface eth0_plumbed:                      [  OK  ]
Shutting down interface eth1_NoWEP:                        [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Setting network parameters:                                [  OK  ]
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth1_NoWEP:                          [  OK  ]

[bpm]$ ifconfig eth1
eth1      Link encap:Ethernet  HWaddr 00:02:6F:04:64:6A
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2536 errors:0 dropped:0 overruns:0 frame:0
          TX packets:662 errors:1 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:365199 (356.6 KiB)  TX bytes:106841 (104.3 KiB)
          Interrupt:11 Memory:e0500000-e0500fff

[bpm]$ netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window 
irtt Iface
192.9.200.0     0.0.0.0         255.255.255.0   U         0 0        
 0 eth1
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0        
 0 lo

[bpm]$ sudo service NetworkManager stop
Stopping NetworkManager daemon:                            [  OK  ]
[bpm]$ nmwa_dbus_get_int():
org.freedesktop.DBus.Error.ServiceDoesNotExist raised:
 Service "org.freedesktop.NetworkManager" does not exist

nmwa_dbus_get_int(): org.freedesktop.DBus.Error.ServiceDoesNotExist
raised:
 Service "org.freedesktop.NetworkManager" does not exist

nmwa_dbus_get_int(): org.freedesktop.DBus.Error.ServiceDoesNotExist
raised:
 Service "org.freedesktop.NetworkManager" does not exist

[bpm]$ sudo service network restart
Shutting down interface eth0_plumbed:                      [  OK  ]
Shutting down interface eth1_NoWEP:                        [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Setting network parameters:                                [  OK  ]
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth1_NoWEP:                          [  OK  ]


[bpm]$ ifconfig eth1
eth1      Link encap:Ethernet  HWaddr 00:02:6F:04:64:6A
          inet addr:192.9.200.35  Bcast:192.9.200.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1291 errors:0 dropped:0 overruns:0 frame:0
          TX packets:48 errors:1 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:117483 (114.7 KiB)  TX bytes:8213 (8.0 KiB)
          Interrupt:11 Memory:e0500000-e0500fff

[bpm]$ netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window 
irtt Iface
192.9.200.0     0.0.0.0         255.255.255.0   U         0 0        
 0 eth1
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0        
 0 lo
0.0.0.0         192.9.200.159   0.0.0.0         UG        0 0        
 0 eth1

FROM /var/log/messages:

Oct 13 09:51:53 indoffcallacctg NetworkManager: Setting network
parameters:  succeeded
Oct 13 09:51:53 indoffcallacctg NetworkManager: starting...
Oct 13 09:51:54 indoffcallacctg NetworkManager:
nm_create_device_and_add_to_list(): adding device 'eth0' (wired)
Oct 13 09:51:54 indoffcallacctg kernel: eth0: link down
Oct 13 09:51:54 indoffcallacctg NetworkManager: Nothing to flush.
Oct 13 09:51:54 indoffcallacctg NetworkManager: Nothing to flush.
Oct 13 09:51:56 indoffcallacctg dhclient: receive_packet failed on
eth1: Network is down
Oct 13 09:51:56 indoffcallacctg NetworkManager:
nm_create_device_and_add_to_list(): adding device 'eth1' (wireless)
Oct 13 09:51:56 indoffcallacctg kernel: eth1: New link status:
Disconnected (0002)
Oct 13 09:51:56 indoffcallacctg NetworkManager: RTNETLINK answers:
File exists
Oct 13 09:51:56 indoffcallacctg kernel: eth1: New link status:
Connected (0001)
Oct 13 09:51:56 indoffcallacctg NetworkManager: AUTO: Best wired
device = (null)Oct 13 09:51:56 indoffcallacctg NetworkManager: AUTO:
Best wireless device = eth1  (INDOFFWAPB1)
Oct 13 09:51:56 indoffcallacctg NetworkManager:     SWITCH: best
device changed
Oct 13 09:51:56 indoffcallacctg NetworkManager:
nm_state_modification_monitor(): beginning activation for device 'eth1'
Oct 13 09:51:56 indoffcallacctg NetworkManager: NetworkManager startup
succeededOct 13 09:51:59 indoffcallacctg kernel: eth1: New link
status: Connected (0001)
Oct 13 09:52:01 indoffcallacctg kernel: eth1: New link status:
Disconnected (0002)
Oct 13 09:52:01 indoffcallacctg kernel: eth1: New link status:
Connected (0001)
Oct 13 09:52:06 indoffcallacctg kernel: eth1: New link status:
Disconnected (0002)
Comment 1 Brian Millett 2004-10-13 11:29:03 EDT
Sorry, I forgot to say that this is with selinux enforced and targeted.
Comment 2 Dan Williams 2004-10-13 11:46:46 EDT
Ok, will look into it.  Note that you _cannot_ use the network scripts
when running NetworkManager, the two are mutually exclusive.
Comment 3 Dan Williams 2004-10-13 11:48:13 EDT
To debug, could you get a root shell and then run:

NetworkManager --no-daemon

and post the output here, letting NM run for a minute or so?
Comment 4 Brian Millett 2004-10-13 12:09:46 EDT
Ok, when you say "network scripts" you mean the stuff in
/etc/sysconfig/network-scripts ?  If so, then the boot option of
'netprofile=<profile>' will also not work?  Then that means the stuff
in /etc/sysconfig/networking/[devices|profiles] also are not used?

If so, then I am in a real brain cramp.  How do I setup profiles, or
wep keys for different sites, or just configure the thing?

I will do the --no-daemon now.

thanks.
Comment 5 Brian Millett 2004-10-13 12:14:48 EDT
So, is the NetworkManager and network services mutually exclusive?

here is the results:
[root@indoffcallacctg ~]# NetworkManager --no-daemon
NetworkManager: starting...
NetworkManager: nm_create_device_and_add_to_list(): adding device
'eth0' (wired)Nothing to flush.
Nothing to flush.
NetworkManager: nm_create_device_and_add_to_list(): adding device
'eth1' (wireless)
RTNETLINK answers: File exists
NetworkManager: AUTO: Best wired device = (null)
NetworkManager: AUTO: Best wireless device = eth1  (INDOFFWAPB1)
NetworkManager:     SWITCH: best device changed
NetworkManager: nm_state_modification_monitor(): beginning activation
for device 'eth1'
NetworkManager: nm_device_activation_worker (eth1) started...
NetworkManager: nm_device_activation_worker(eth1): waiting for an
access point.
NetworkManager: nm_device_activation_worker(eth1): waiting for an
access point.
Nothing to flush.
NetworkManager: nm_device_activation_worker(eth1): waiting for an
access point.
NetworkManager: nm_device_activation_worker(eth1): waiting for an
access point.
NetworkManager: nm_device_activation_worker(eth1): waiting for an
access point.
Nothing to flush.
NetworkManager: nm_device_activation_worker(eth1): waiting for an
access point.
NetworkManager: nm_device_activation_worker(eth1): waiting for an
access point.
NetworkManager: nm_device_activation_worker(eth1): waiting for an
access point.
Nothing to flush.
NetworkManager: nm_device_activation_worker(eth1): waiting for an
access point.
NetworkManager: nm_device_activation_worker(eth1): waiting for an
access point.
Nothing to flush.
NetworkManager: nm_device_activation_worker(eth1): waiting for an
access point.
NetworkManager: nm_device_activation_worker(eth1): waiting for an
access point.
NetworkManager: nm_device_activation_worker(eth1): waiting for an
access point.
Nothing to flush.
NetworkManager: nm_device_activation_worker(eth1): waiting for an
access point.
NetworkManager: nm_device_activation_worker(eth1): waiting for an
access point.
Nothing to flush.
NetworkManager: nm_device_activation_worker(eth1): waiting for an
access point.
NetworkManager: nm_device_activation_worker(eth1): waiting for an
access point.
NetworkManager: nm_device_activation_worker(eth1): waiting for an
access point.
Nothing to flush.
NetworkManager: nm_device_activation_worker(eth1): waiting for an
access point.
NetworkManager: nm_device_activation_worker(eth1): waiting for an
access point.
Nothing to flush.
NetworkManager: nm_device_activation_worker(eth1): waiting for an
access point.
NetworkManager: nm_device_activation_worker(eth1): waiting for an
access point.
NetworkManager: nm_device_activation_worker(eth1): waiting for an
access point.

Comment 6 Dan Williams 2004-10-13 20:36:44 EDT
Yes, they are mutually exclusive.  Much of the point of NetworkManager
was to get rid of profiles for laptop users.  This is accomplished by
attempting to use DHCP as much as possible, which is the case in most
sane networks (except for highly-secured government installations
we've heard).

NetworkManager takes care of all your WEP needs.  You must also
install the NetworkManager-gnome package, which dumps a user-side
daemon and a panel applet onto your box.  After running
NetworkManager, as your own user run "NetworkManagerInfo".  This will
add an applet to your panel (in the notification area), and when you
click it you should be able to see a list of wireless networks your
card can see.  When you click one of these, NM will attempt to connect
to it.  If you need a WEP key, a dialog will pop up asking you for it.
 Enter either the Hex key or the passphrase (make sure you choose
which type from the pop-down) and hit OK/Connect.  If all is well, you
should see 4 blue pips underneath the "WiFi" icon.

The WEP key is now stored and NetworkManager will now attempt to
connect to that access point when its in range, and will use the
stored WEP key from now on.


---------------------------------------

In your posts above, are you connected to a wired network?  I'm
curious because if you are, then your ethernet card isn't up to snuff
:(  Can you give me two things?

1) lspci
2) cardctl info

and paste those two commands into this bug report.

Thanks!
Dan
Comment 7 Dan Williams 2004-10-13 20:42:28 EDT
As a side note, the normal "ifup/ifdown" scripts confuse
NetworkManager because it changes the interface characteristics
underneath NM.  Besides, if you ifup an interface, NM will just bring
it back down again, or will wipe out its IP address and routes if its
not the currently active interface.  This is completely by design,
since NM is supposed to control the network.  As a user, you can use
the panel-applet to control your network connections rather than using
"ifup/ifdown".

If you need static IP support, you can configure your card for static
IP addressing with system-config-network, and NM _will_ respect that
information as long as you have IP+netmask+gateway.  But of course,
you loose the ability to roam on that connection, so I wouldn't
suggest it for a wireless card on a laptop.

NetworkManager isn't really meant for a server-side situation, though
it would work there.  Its really meant for a laptop user who fairly
frequently changes network settings, for example I take my laptop from
home to work and back and have completely different access points for
each.
Comment 8 Brian Millett 2004-10-14 09:45:09 EDT
Ok, here is the results, plus at the end, I have more questions.
(I am not connected to a wired lan, wifi right now)

cardctl info:
00:00.0 Host bridge: Intel Corp. 82852/82855 GM/GME/PM/GMV Processor
to I/O Controller (rev 01)
00:00.1 System peripheral: Intel Corp. 82852/82855 GM/GME/PM/GMV
Processor to I/O Controller (rev 01)
00:00.3 System peripheral: Intel Corp. 82852/82855 GM/GME/PM/GMV
Processor to I/O Controller (rev 01)
00:02.0 VGA compatible controller: Intel Corp. 82852/855GM Integrated
Graphics Device (rev 01)
00:02.1 Display controller: Intel Corp. 82852/855GM Integrated
Graphics Device (rev 01)
00:1d.0 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corp. 82801DB/DBM (ICH4/ICH4-M) USB2
EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corp. 82801 Mobile PCI Bridge (rev 83)
00:1f.0 ISA bridge: Intel Corp. 82801DBM (ICH4-M) LPC Interface Bridge
(rev 03)
00:1f.1 IDE interface: Intel Corp. 82801DBM (ICH4-M) IDE Controller
(rev 03)
00:1f.3 SMBus: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus
Controller (rev 03)
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
00:1f.6 Modem: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97
Modem Controller (rev 03)
02:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
02:02.0 Network controller: Intersil Corporation Prism 2.5 Wavelan
chipset (rev 01)
02:04.0 CardBus bridge: O2 Micro, Inc. OZ6933 Cardbus Controller (rev 01)
02:04.1 CardBus bridge: O2 Micro, Inc. OZ6933 Cardbus Controller (rev 01)
PRODID_1=""
PRODID_2=""
PRODID_3=""
PRODID_4=""
MANFID=0000,0000
FUNCID=255
PRODID_1=""
PRODID_2=""
PRODID_3=""
PRODID_4=""
MANFID=0000,0000
FUNCID=255

lspci:
00:00.0 Host bridge: Intel Corp. 82852/82855 GM/GME/PM/GMV Processor
to I/O Controller (rev 01)
00:00.1 System peripheral: Intel Corp. 82852/82855 GM/GME/PM/GMV
Processor to I/O Controller (rev 01)
00:00.3 System peripheral: Intel Corp. 82852/82855 GM/GME/PM/GMV
Processor to I/O Controller (rev 01)
00:02.0 VGA compatible controller: Intel Corp. 82852/855GM Integrated
Graphics Device (rev 01)
00:02.1 Display controller: Intel Corp. 82852/855GM Integrated
Graphics Device (rev 01)
00:1d.0 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corp. 82801DB/DBM (ICH4/ICH4-M) USB2
EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corp. 82801 Mobile PCI Bridge (rev 83)
00:1f.0 ISA bridge: Intel Corp. 82801DBM (ICH4-M) LPC Interface Bridge
(rev 03)
00:1f.1 IDE interface: Intel Corp. 82801DBM (ICH4-M) IDE Controller
(rev 03)
00:1f.3 SMBus: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus
Controller (rev 03)
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 03)
00:1f.6 Modem: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97
Modem Controller (rev 03)
02:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
02:02.0 Network controller: Intersil Corporation Prism 2.5 Wavelan
chipset (rev 01)
02:04.0 CardBus bridge: O2 Micro, Inc. OZ6933 Cardbus Controller (rev 01)
02:04.1 CardBus bridge: O2 Micro, Inc. OZ6933 Cardbus Controller (rev 01)

 lshal | grep net\.
lshal version 0.2.98.cvs20040929
  info.capabilities = 'net net.80203'  (string)
  net.linux.sysfs_path = '/sys/class/net/eth0'  (string)
  net.interface = 'eth0'  (string)
  net.address = '00:02:3f:8f:19:0e'  (string)
  net.interface_up = false  (bool)
  net.linux.ifindex = 2  (0x2)  (int)
  net.80203.mac_address = 9656277262  (0x23f8f190e)  (uint64)
  net.arp_proto_hw_id = 1  (0x1)  (int)
  net.media = 'Ethernet'  (string)
  info.category = 'net.80203'  (string)
  info.capabilities = 'net.80211 net'  (string)
  net.linux.sysfs_path = '/sys/class/net/eth1'  (string)
  net.interface = 'eth1'  (string)
  net.address = '00:02:6f:04:64:6a'  (string)
  net.interface_up = true  (bool)
  net.linux.ifindex = 3  (0x3)  (int)
  net.80211.mac_address = 10452493418  (0x26f04646a)  (uint64)
  net.arp_proto_hw_id = 1  (0x1)  (int)
  net.media = 'Ethernet'  (string)
  info.category = 'net.80211'  (string)

------------------------  Questions --------------------

Ok, it looks like the "old" way of having
/etc/sysconfig/networking/[devices|profiles] is not used by the
networkmanager.  I also assume that the files in
/etc/sysconfig/network-scripts are not used.  Correct? 
If I have anything in network-scripts, then the ifcfg-eth0,ifcfg-eth1
should be very basic/default and have 'ONBOOT=no' or something like:
IPV6INIT=no
ONBOOT=no
USERCTL=yes
PEERDNS=yes
TYPE=Ethernet
DEVICE=eth0
HWADDR=00:02:3f:8f:19:0e
BOOTPROTO=dhcp
NOZEROCONF=yes

Then when I boot, there will be no ethernet active, and the ipaddr of
the laptop will be 127.0.0.1 . 
Or does the NM probe each interface to see if it is 'connected' and
try to activate the interface at that time?  If so, is this when NM is
started?
Or will the NM just pick a default?  
If no addr at first, then the X11 session will be owned by localhost.
 If I then connect using the applet to the wireless accesspoint of
choice, I'll get a new ipaddr using DHCP.  Then I need to logout and
get a new X11 session owned by the new 'host'.  

Is the NM window manager agnostic?

I take it that right now, this will not work for KDE, just GNOME.

Since this is a laptop that I do a lot of testing on, Services like
ldap, mysql, httpd, etc. should be configured to be accepting
connections from localhost or I'll have problems at boot time.

Thanks for the help.

Comment 9 Dan Williams 2004-10-14 09:56:07 EDT
> Ok, it looks like the "old" way of having
> /etc/sysconfig/networking/[devices|profiles] is not used by the
> networkmanager.  I also assume that the files in
> /etc/sysconfig/network-scripts are not used.  Correct? 

Half-correct :)  NetworkManager looks in these files, if they exist
for the device, and checks the BOOTPROTO line.  If the bootproto line
is "dhcp", then NetworkManager will use DHCP on that interface.  If
the BOOTPROTO line is "static", then NetworkManager _will_ honor the
static IP information in the ifcfg-* file when it activates the interface.

> Or does the NM probe each interface to see if it is 'connected' and
> try to activate the interface at that time?  If so, is this when NM
> is started?

When NM starts, it gets list of all available interfaces from hal.  It
then goes through a process to find the "best" interface.  Wired
interfaces are preferred, but _only_ when they are plugged in and have
an active link.  Next, wireless interfaces are used.

> If no addr at first, then the X11 session will be owned by
> localhost.
> If I then connect using the applet to the wireless accesspoint
> of choice, I'll get a new ipaddr using DHCP.  Then I need to logout
> and get a new X11 session owned by the new 'host'.

NetworkManager grabs the hostname before it runs DHCP, and sets that
same hostname back after DHCP finishes.  So you shouldn't have a
problem with X11/xauth's stupidity about hostnames.

> Is the NM window manager agnostic?

NetworkManager is completely agnostic, but NetworkManagerInfo and the
panel applet are gnome applications.  However, since the panel applet
is actually a Notificiation Area icon, you can use then under KDE as
well even though they are really gnome applications.

What you should do is set NetworkManager to run on startup using
chkconfig, and then add NetworkManagerInfo (from the
NetworkManager-gnome package) to your session so that it starts up
when you log in.

NM won't connect to any wireless network until you tell it to, and the
way it gets that information is to query NetworkManagerInfo, which is
run when you log in.  NMI stores the wireless network information in
GConf, which is why its a user-side daemon.  Until NMI is run, NM will
just spin and wait for NMI to launch.

So I think the problem you're having here is that you're expecting a
network connection to be up and running without having run
NetworkManagerInfo and chosen a wireless network to use.
Comment 10 Brian Millett 2004-10-14 11:55:18 EDT
Thanks.  So this is what I did to get it to work.

I had many profiles for different locations.  The current location, my
profile had devices ifcfg-eth0_plumbed and ifcfg-eth1_NoWEP.  With
this profile active, starting NetworkManager caused the errors I
posted at first.  With your discription of the process, I created a
default profile that had default devices (ifcfg-eth0, ifcfg-eth1).  I
did not change the files, meaning that they are the same as
ifcfg-eth0_plumbed & ifcfg-eth1_NoWEP.  I then started NetworkManager,
then NetworkManagerInfo.
It now works as advertised.  I rebooted, and it works great.  The only
modification to my configuration was to make each interface ONBOOT=no.

Now I need to get my zaurus and usb0 to work again.  Should I just
send email to the list about that?
Comment 11 John Thacker 2004-12-11 16:56:30 EST
"NetworkManager isn't really meant for a server-side situation, though
it would work there."

So if I understand correctly, NetworkManager is completely unable to work with
Internet connection sharing, then, at least on the box sharing the connection? 
Connection sharing usually requires an interface with a static configuration but
no gateway listed, but NetworkManager then wants to set that interface via DHCP
instead of respecting the static settings.
Comment 12 Dan Williams 2005-01-29 16:45:54 EST
Yes, that's basically correct, its not mean to work with connection
sharing at this time.  Planned for the future though (to allow more
than 1 interface up at the same time.)

Note You need to log in before you can comment on or make changes to this bug.