Bug 135564 - dmidecode should be removed on all platforms execept x86
dmidecode should be removed on all platforms execept x86
Status: CLOSED DUPLICATE of bug 88377
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel-utils (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-13 11:30 EDT by Bill Peck
Modified: 2015-01-04 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-02 02:04:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2004-10-13 11:30:14 EDT
Description of problem:
dmidecode is present on platforms other than x86.  If called this can
cause Machine Checks.

Version-Release number of selected component (if applicable):
kernel-utils-2.4-8.37.6

How reproducible:


Steps to Reproduce:
1. install U3 or U4 on HP rx8620
2. run dmidecode
3.
  
Actual results:

Logging TOGO Errors ....
    Size of TOGO Errors : 0x0
                                                Complete
 Finish the Error Event Logging ....
                                                Complete
 Flush the cpu cache ....
                                                Complete
 ReEnabling CPU Poison Check ....
                                                Complete
Cpu0: MCA Rendez Always flag set to 1.
Cpu0: Perform rendezvous started.
Cpu0: Sent Rendez vector number 0xe8 to 7.
Cpu0: Rendezvous timeout : 20000
Cpu0: Waiting processors to acknowledge MCA vector.
Unable to handle kernel paging request at virtual address 0000070eff84a708
swapper[0]: Oops 8813272891392
                               
Pid: 0, comm:              swapper
EIP is at xfrm_policy_list_Rsmp_71f01109 [] 0xfab61fe8 (2.4.21-21.EL)
psr : 0000101008022018 ifs : 8000000000000f25 ip  :
[<e000070eff8388c0>]    Not tainted
unat: 0000000000000000 pfs : 0000000000000f25 rsc : 0000000000000003
rnat: 80000ffc1002c690 bsps: 0000000000000008 pr  : 80000000ff7ad965
ldrs: 0000000000000000 ccv : 0000000000000000 fpsr: 0009804c0270033f
b0  : e000070eff8388a0 b6  : c0000000ffd7c9e0 b7  : e000070eff409000
f6  : 1003e000000004325c53f f7  : 1003e000000000077cbcb
f8  : 1003e0000000000000000 f9  : 1003e0000000000000000
r1  : e000070eff830000 r2  : e000000160b1f7f0 r3  : 0000000000000000
r8  : 0000000000000002 r9  : 00000000000000ff r10 : 0000000000000000
r11 : c0000ffc1011acf0 r12 : e000000160b1f8f0 r13 : e000000160b18000
r14 : 0000000000000040 r15 : 00000000001f0000 r16 : e000000160b1f658
r17 : e000000160b1f660 r18 : e000000160b1f668 r19 : e000000160b1f6a8
r20 : e000000160b1f698 r21 : e000000160b1f690 r22 : 0000001008022018
r23 : c0000ffc20100000 r24 : e000000004b98a64 r25 : 0000000000000004
r26 : e000000004b98a60 r27 : e000000004b98a60 r28 : 0000000000000004
r29 : e000000160b1803c r30 : e000000004a85690 r31 : e000000160b18028
                                                                     
Call Trace: [<e000000004415960>] sp=0xe000000160b1f4f0
bsp=0xe000000160b19548 show_stack [kernel] 0x80
[<e000000004431d30>] sp=0xe000000160b1f6c0 bsp=0xe000000160b19520 die
[kernel] 0x1b0
[<e000000004451530>] sp=0xe000000160b1f6c0 bsp=0xe000000160b194c8
ia64_do_page_fault [kernel] 0x350
[<e00000000440ea20>] sp=0xe000000160b1f750 bsp=0xe000000160b194c8
ia64_leave_kernel [kernel] 0x0
[<e000070eff8388c0>] sp=0xe000000160b1f8f0 bsp=0xe000000160b193d0
xfrm_policy_list_Rsmp_71f01109 [] 0xfab61fe8
 <0>Kernel panic: Aiee, killing interrupt handler!
In interrupt handler - not syncing
                                   
Cpu0: Sending INIT to other processors for Rendezvous.
Cpu0: Waiting processors to acknowledge INIT.
Cpu0: All processors did not respond to INIT.
Cpu0: Perform rendezvous complete, RendezState : 0xffffffffffffffff .
  Cell local CallGate Pointer 0x70eff409000
  CallGate Pointer after moving to CoreCell 0x70eff409000
 Firmware executing from Main Memory .......
Calling OS_MCA at 0x000000000444d5a0...


Expected results:
either the command should work and not MCA.  or we should remove it. 
Our own redhat ready cert caused the above.

Additional info:
Comment 1 Dave Jones 2005-03-02 02:04:25 EST

*** This bug has been marked as a duplicate of 88377 ***

Note You need to log in before you can comment on or make changes to this bug.