Bug 135581 - multimedia keys don't work on my dell keyboard
multimedia keys don't work on my dell keyboard
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-13 13:25 EDT by Thomas J. Baker
Modified: 2013-04-02 00:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-04 08:33:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2004-10-13 13:25:38 EDT
Description of problem:

I didn't know where to file this so it went against distribution. Mike
Harris just closed (this week) a long standing and forgotton bug of
mine about the multimedia keys on my Dell keyboard not working, saying
it either should work or be filed upstream. This prompted me to try
them again and indeed they worked fine until todays (10/13/2004)
development upgrade. They were working after yesterdays update and
reboot but they broke today after the reboot. I thought it may be the
kernel so I booted yesterdays kernel-smp-2.6.8-1.603 as a test but
that didn't help. xorg-x11 hasn't been updated since 28 September so
it had to be something in todays updates that broke them. (That's why
I filed it here and not at fdo bugzilla).

Here are the updates that occurred on my system:

wintermute> rpm -qa --last
gnome-volume-manager-1.1.0-4                  Wed 13 Oct 2004 11:25:41
AM EDT
gnome-desktop-devel-2.8.0-3                   Wed 13 Oct 2004 11:25:40
AM EDT
libungif-devel-4.1.3-1                        Wed 13 Oct 2004 11:25:39
AM EDT
libpcap-0.8.3-7                               Wed 13 Oct 2004 11:25:39
AM EDT
udev-035-1                                    Wed 13 Oct 2004 11:25:37
AM EDT
gpdf-2.8.0-2                                  Wed 13 Oct 2004 11:25:34
AM EDT
neon-0.24.7-4                                 Wed 13 Oct 2004 11:25:33
AM EDT
gpm-devel-1.20.1-57                           Wed 13 Oct 2004 11:25:32
AM EDT
libtiff-devel-3.6.1-6                         Wed 13 Oct 2004 11:25:31
AM EDT
system-config-printer-gui-0.6.115-1           Wed 13 Oct 2004 11:25:29
AM EDT
kudzu-1.1.95-1                                Wed 13 Oct 2004 11:25:28
AM EDT
totem-0.99.18-2                               Wed 13 Oct 2004 11:25:25
AM EDT
prelink-0.3.2-11                              Wed 13 Oct 2004 11:25:24
AM EDT
selinux-policy-targeted-1.17.30-2             Wed 13 Oct 2004 11:25:23
AM EDT
vim-X11-6.3.030-2                             Wed 13 Oct 2004 11:25:22
AM EDT
vim-enhanced-6.3.030-2                        Wed 13 Oct 2004 11:25:21
AM EDT
glibc-devel-2.3.3-67                          Wed 13 Oct 2004 11:25:19
AM EDT
system-config-securitylevel-1.4.9-1           Wed 13 Oct 2004 11:25:17
AM EDT
gnome-panel-devel-2.8.1-1                     Wed 13 Oct 2004 11:25:17
AM EDT
system-config-services-0.8.14-1               Wed 13 Oct 2004 11:25:16
AM EDT
jfsutils-1.1.7-1                              Wed 13 Oct 2004 11:25:15
AM EDT
nscd-2.3.3-67                                 Wed 13 Oct 2004 11:25:14
AM EDT
cryptsetup-0.1-4                              Wed 13 Oct 2004 11:25:14
AM EDT
vim-minimal-6.3.030-2                         Wed 13 Oct 2004 11:25:13
AM EDT
pam_ccreds-1-3                                Wed 13 Oct 2004 11:25:13
AM EDT
epiphany-1.4.4-2                              Wed 13 Oct 2004 11:25:08
AM EDT
kernel-utils-2.4-13.1.34                      Wed 13 Oct 2004 11:25:06
AM EDT
vino-2.8.1-1                                  Wed 13 Oct 2004 11:25:04
AM EDT
gconf-editor-2.8.0-2                          Wed 13 Oct 2004 11:25:03
AM EDT
kudzu-devel-1.1.95-1                          Wed 13 Oct 2004 11:25:02
AM EDT
evolution-data-server-devel-1.0.2-2           Wed 13 Oct 2004 11:25:00
AM EDT
make-3.80-5                                   Wed 13 Oct 2004 11:24:57
AM EDT
iiimf-libs-devel-12.0.1-14.svn1943            Wed 13 Oct 2004 11:24:56
AM EDT
mod_python-3.1.3-5                            Wed 13 Oct 2004 11:24:54
AM EDT
policycoreutils-1.17.6-2                      Wed 13 Oct 2004 11:24:53
AM EDT
NetworkManager-gnome-0.2-4                    Wed 13 Oct 2004 11:24:52
AM EDT
libmng-devel-1.0.8-1                          Wed 13 Oct 2004 11:24:52
AM EDT
gnome-netstatus-2.8.0-3                       Wed 13 Oct 2004 11:24:49
AM EDT
evolution-devel-2.0.2-1                       Wed 13 Oct 2004 11:24:46
AM EDT
krbafs-devel-1.2.2-6                          Wed 13 Oct 2004 11:24:45
AM EDT
tcpdump-3.8.2-7                               Wed 13 Oct 2004 11:24:44
AM EDT
setarch-1.5-1                                 Wed 13 Oct 2004 11:24:44
AM EDT
krbafs-1.2.2-6                                Wed 13 Oct 2004 11:24:42
AM EDT
parted-1.6.15-3                               Wed 13 Oct 2004 11:24:41
AM EDT
guile-1.6.4-14                                Wed 13 Oct 2004 11:24:38
AM EDT
libungif-4.1.3-1                              Wed 13 Oct 2004 11:24:37
AM EDT
binutils-2.15.92.0.2-3                        Wed 13 Oct 2004 11:24:35
AM EDT
file-4.10-2                                   Wed 13 Oct 2004 11:24:34
AM EDT
iiimf-libs-12.0.1-14.svn1943                  Wed 13 Oct 2004 11:24:33
AM EDT
libmng-1.0.8-1                                Wed 13 Oct 2004 11:24:32
AM EDT
mysql-3.23.58-13                              Wed 13 Oct 2004 11:24:29
AM EDT
system-config-printer-0.6.115-1               Wed 13 Oct 2004 11:24:10
AM EDT
nautilus-2.8.1-2                              Wed 13 Oct 2004 11:23:58
AM EDT
NetworkManager-0.2-4                          Wed 13 Oct 2004 11:23:52
AM EDT
glibc-headers-2.3.3-67                        Wed 13 Oct 2004 11:23:49
AM EDT
system-config-securitylevel-tui-1.4.9-1       Wed 13 Oct 2004 11:23:46
AM EDT
shadow-utils-4.0.3-31                         Wed 13 Oct 2004 11:23:43
AM EDT
gtk2-devel-2.4.13-1                           Wed 13 Oct 2004 11:23:33
AM EDT
atk-devel-1.8.0-2                             Wed 13 Oct 2004 11:23:30
AM EDT
gnome-panel-2.8.1-1                           Wed 13 Oct 2004 11:23:25
AM EDT
libwnck-2.8.1-1                               Wed 13 Oct 2004 11:23:22
AM EDT
GConf2-devel-2.8.1-1                          Wed 13 Oct 2004 11:23:21
AM EDT
libsoup-devel-2.2.1-1                         Wed 13 Oct 2004 11:23:20
AM EDT
libgal2-devel-2.2.3-1                         Wed 13 Oct 2004 11:23:18
AM EDT
evolution-2.0.2-1                             Wed 13 Oct 2004 11:23:08
AM EDT
vim-common-6.3.030-2                          Wed 13 Oct 2004 11:22:56
AM EDT
libgal2-2.2.3-1                               Wed 13 Oct 2004 11:22:52
AM EDT
evolution-data-server-1.0.2-2                 Wed 13 Oct 2004 11:22:47
AM EDT
libsoup-2.2.1-1                               Wed 13 Oct 2004 11:22:45
AM EDT
gnome-desktop-2.8.0-3                         Wed 13 Oct 2004 11:22:43
AM EDT
GConf2-2.8.1-1                                Wed 13 Oct 2004 11:22:39
AM EDT
gtk2-2.4.13-1                                 Wed 13 Oct 2004 11:22:33
AM EDT
libtiff-3.6.1-6                               Wed 13 Oct 2004 11:22:31
AM EDT
gpm-1.20.1-57                                 Wed 13 Oct 2004 11:22:30
AM EDT
perl-5.8.5-9                                  Wed 13 Oct 2004 11:22:25
AM EDT
atk-1.8.0-2                                   Wed 13 Oct 2004 11:22:16
AM EDT
glibc-2.3.3-67                                Wed 13 Oct 2004 11:21:56
AM EDT
glibc-common-2.3.3-67                         Wed 13 Oct 2004 11:21:33
AM EDT
hwdata-0.143-1                                Wed 13 Oct 2004 11:21:22
AM EDT
redhat-artwork-0.113-1                        Wed 13 Oct 2004 11:21:16
AM EDT
redhat-menus-1.9-2                            Wed 13 Oct 2004 11:21:03
AM EDT
kernel-smp-2.6.8-1.610                        Wed 13 Oct 2004 11:18:27
AM EDT
control-center-2.8.0-11                       Tue 12 Oct 2004 01:55:18
PM EDT
nautilus-cd-burner-2.8.3-5                    Tue 12 Oct 2004 01:55:14
PM EDT
gnome-python2-2.6.0-3                         Tue 12 Oct 2004 01:55:13
PM EDT
gnome-python2-gconf-2.6.0-3                   Tue 12 Oct 2004 01:55:03
PM EDT

and the list goes on from there.


Version-Release number of selected component (if applicable):
control-center-2.8.0-11, xorg-x11-6.8.1-4

How reproducible:
Everytime.

Steps to Reproduce:
1.set keyboard to 'dell' in keyboard prefs
2.mm keys are not recognized in 'keyboard shortcuts' pref
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Thomas J. Baker 2004-10-15 11:07:23 EDT
After yesterdays devel updates (10/14/2004) the keys are recognized by
the keyboard shortcuts app and volume up, down, and mute work. The
other keys bound to play, pause, stop, previous, and next don't work
in rhythmbox though. Since rhythmbox hasn't been updated since the
6th, I'm guessing it should stay here since it was working before the
13th.
Comment 2 Thomas J. Baker 2004-10-25 16:08:05 EDT
On Friday (10/25/2004) things were working fine again. Today, none of
them work again. X was updated on Friday so that might have broken it
but I rebooted after Friday's updates and I think they were still
working. Today there were only a handful of updates in rawhide and
none of the keys work. I don't know if they were working before todays
update or not.
Comment 3 Thomas J. Baker 2004-11-02 15:20:04 EST
As of late last week, things are working fine now. All keyboard
buttons work.
Comment 4 Marco Pesenti Gritti 2004-11-04 08:33:10 EST
Closing then.

Note You need to log in before you can comment on or make changes to this bug.