Bug 135603 - ftp installer should check path EARLIER
Summary: ftp installer should check path EARLIER
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-13 18:59 UTC by Mike Perry
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-21 15:37:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike Perry 2004-10-13 18:59:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040707 Firefox/0.9.2 StumbleUpon/1.998

Description of problem:
I was very frustrated to go through the majority of the option
selection process only to be met with a hung installer after selecting
my root password because I had not entered the correct path to the ftp
install directory. There was no recovery at this point, the system
would not let me go back to enter a new ftp path, because that
selection had been done during the text mode portion. Furthermore the
error presented by the GUI was not very informative. I had to switch
to the console to determine what went wrong.

Suggestions:
1. Have the text-mode installer verify it can access the package list
AS SOON AS you enter the ftp directory, and prompt you for another
location if it is incorrect.

- or -

2. Have anaconda present you with a dialog box to enter a new
installation path if it can't find the hdlist.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Choose a valid but incomplete ftp installation path: ex
mirror.stanford.edu /pub/mirror/fedora/linux/core
2. Fill in all interim choices
3. Wait for installer to hang after you enter your root password
    

Additional info:

Comment 1 Jeremy Katz 2004-10-18 14:30:55 UTC
Fixed in CVS


Note You need to log in before you can comment on or make changes to this bug.