Bug 135623 - klaptop_acpi_helper has size/checksum problem (build error?)
Summary: klaptop_acpi_helper has size/checksum problem (build error?)
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdeutils (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-13 20:48 UTC by John W. Lockhart
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-08 09:38:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John W. Lockhart 2004-10-13 20:48:07 UTC
Description of problem:
Control center gets error when trying to set up the acpi
helper -- application doesn't have same size/checksum as
when compiled.

Version-Release number of selected component (if applicable):
kdeutils-3.3.0-2.i386

How reproducible, with steps:
Boot FC3-t3 with acpi enabled, start a KDE session, and
launch Control Center.

Go to PowerControl/LaptopBattery, and click the rightmost
tab, "ACPI Config".  Scroll to the bottom, and click
the "Setup Helper Application" button.  Observe dialog.
(Only tested on one laptop thus far -- mine...)

Actual results:

"The /usr/bin/klaptop_acpi_helper application does not seem to have
the same size or checksum as when it was compiled we do NOT recommend
you proceed with making it setuid-root without further investigation"

Trivial additional bug: run-on sentence.  Should be:
..."compiled.  We do NOT"... and ... "investigation."

Expected results:

Smoothly enable ACPI features with helper.  (I just chmod'd 
the relevant item(s) in /proc, since I'm the only one ever
on my laptop.)

Additional info:

Comment 1 Muyi Taiwo 2005-09-07 12:00:13 UTC
(In reply to comment #0)
This bug is also present in fc4 -- kdeutils-3.4.0-1 -- on a Toshiba TE2000
laptop, but seems to only occur when using kernel version 2.6.12-1.1447_FC4.  It
does not occur with the eralier kernel 2.6.11-1.1369_FC4

The file /proc/acpi/sleep does not exist in my installation.  So, since I have
both kernels installed, I simply keep running the older kernel.

Muyiwa


> Description of problem:
> Control center gets error when trying to set up the acpi
> helper -- application doesn't have same size/checksum as
> when compiled.
> 
> Version-Release number of selected component (if applicable):
> kdeutils-3.3.0-2.i386
> 
> How reproducible, with steps:
> Boot FC3-t3 with acpi enabled, start a KDE session, and
> launch Control Center.
> 
> Go to PowerControl/LaptopBattery, and click the rightmost
> tab, "ACPI Config".  Scroll to the bottom, and click
> the "Setup Helper Application" button.  Observe dialog.
> (Only tested on one laptop thus far -- mine...)
> 
> Actual results:
> 
> "The /usr/bin/klaptop_acpi_helper application does not seem to have
> the same size or checksum as when it was compiled we do NOT recommend
> you proceed with making it setuid-root without further investigation"
> 

Comment 2 Ngo Than 2005-09-08 09:38:52 UTC
The bug is now fixed in kdeutils-3.4.2-2, which is available in rawhide. 
I will do fc3 update soon. Thanks for your report. 


Note You need to log in before you can comment on or make changes to this bug.