Bug 135623 - klaptop_acpi_helper has size/checksum problem (build error?)
klaptop_acpi_helper has size/checksum problem (build error?)
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kdeutils (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-13 16:48 EDT by John W. Lockhart
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-08 05:38:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John W. Lockhart 2004-10-13 16:48:07 EDT
Description of problem:
Control center gets error when trying to set up the acpi
helper -- application doesn't have same size/checksum as
when compiled.

Version-Release number of selected component (if applicable):
kdeutils-3.3.0-2.i386

How reproducible, with steps:
Boot FC3-t3 with acpi enabled, start a KDE session, and
launch Control Center.

Go to PowerControl/LaptopBattery, and click the rightmost
tab, "ACPI Config".  Scroll to the bottom, and click
the "Setup Helper Application" button.  Observe dialog.
(Only tested on one laptop thus far -- mine...)

Actual results:

"The /usr/bin/klaptop_acpi_helper application does not seem to have
the same size or checksum as when it was compiled we do NOT recommend
you proceed with making it setuid-root without further investigation"

Trivial additional bug: run-on sentence.  Should be:
..."compiled.  We do NOT"... and ... "investigation."

Expected results:

Smoothly enable ACPI features with helper.  (I just chmod'd 
the relevant item(s) in /proc, since I'm the only one ever
on my laptop.)

Additional info:
Comment 1 Muyi Taiwo 2005-09-07 08:00:13 EDT
(In reply to comment #0)
This bug is also present in fc4 -- kdeutils-3.4.0-1 -- on a Toshiba TE2000
laptop, but seems to only occur when using kernel version 2.6.12-1.1447_FC4.  It
does not occur with the eralier kernel 2.6.11-1.1369_FC4

The file /proc/acpi/sleep does not exist in my installation.  So, since I have
both kernels installed, I simply keep running the older kernel.

Muyiwa


> Description of problem:
> Control center gets error when trying to set up the acpi
> helper -- application doesn't have same size/checksum as
> when compiled.
> 
> Version-Release number of selected component (if applicable):
> kdeutils-3.3.0-2.i386
> 
> How reproducible, with steps:
> Boot FC3-t3 with acpi enabled, start a KDE session, and
> launch Control Center.
> 
> Go to PowerControl/LaptopBattery, and click the rightmost
> tab, "ACPI Config".  Scroll to the bottom, and click
> the "Setup Helper Application" button.  Observe dialog.
> (Only tested on one laptop thus far -- mine...)
> 
> Actual results:
> 
> "The /usr/bin/klaptop_acpi_helper application does not seem to have
> the same size or checksum as when it was compiled we do NOT recommend
> you proceed with making it setuid-root without further investigation"
> 
Comment 2 Ngo Than 2005-09-08 05:38:52 EDT
The bug is now fixed in kdeutils-3.4.2-2, which is available in rawhide. 
I will do fc3 update soon. Thanks for your report. 

Note You need to log in before you can comment on or make changes to this bug.