Bug 135658 - error: V3 DSA signature: BAD, key ID db42a60e
error: V3 DSA signature: BAD, key ID db42a60e
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: rpmdb-redhat (Show other bugs)
2.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Powers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-14 02:25 EDT by Muralidharan
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-15 10:28:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Muralidharan 2004-10-14 02:25:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040113

Description of problem:
I installed glibc libraries in my machine.  

I got error when execution the below command
 
rpm -ivh svnpkg/glibc-debug-2.3.2-11.9.i386.rpm

The below error has occured.

error: svnpkg/glibc-debug-2.3.2-11.9.i386.rpm: V3 DSA signature: BAD,
key ID db42a60e
error: svnpkg/glibc-debug-2.3.2-11.9.i386.rpm cannot be installed


i thought rpmdb has been broked.

so i ran these command

cd /var/lib/rpm
rm -f __db.00[123]
rpm --rebuilddb

but i didnt get any change

after i did these commands

zip rpm_backup.zip *
then always in that /var/lib/rpm directory :
mv Pubkeys Pubkeys.old
rpm --rebuilddb -vv

But there is no change. So could anyone give me solution for this.

Thanks,

Muralidharan



Version-Release number of selected component (if applicable):
rpm-4.1

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1.cd /var/lib/rpm
rm -f __db.00[123]
rpm --rebuilddb

2.zip rpm_backup.zip *
then always in that /var/lib/rpm directory :
mv Pubkeys Pubkeys.old
rpm --rebuilddb -vv

3.
    

Actual Results:  Nothing 

Additional info:
Comment 1 Suzanne Hillman 2004-10-14 14:45:57 EDT
Where did the glibc-debug rpm come from? It might really be that the
signature is bad.
Comment 2 Tim Powers 2004-10-15 10:28:26 EDT
You need to make sure that you have the gpg keys imported into RPM that the package is signed 
with. The GPG signatures are located on disc1, and can be imported by invoking:

 rpm --import <gpg-key>

Note You need to log in before you can comment on or make changes to this bug.