Bug 135722 - NetworkManager will not allow zaurus to sync via usb0
NetworkManager will not allow zaurus to sync via usb0
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-14 13:27 EDT by Brian Millett
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: NetworkManager-0.4-34.cvs20050729
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-09 13:43:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Millett 2004-10-14 13:27:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041012
Firefox/0.10.1

Description of problem:
With NetworkManager active, I can not add a route to the zaurus via
usb0.  The route keeps getting torn down.

Version-Release number of selected component (if applicable):
NetworkManager-0.2-4

How reproducible:
Always

Steps to Reproduce:
1.have NetworkManager active
2.plug in zaurus
3.try to sync
    

Actual Results:  no route to host.

Expected Results:  should have a route to the zaurus via usb0

Additional info:

Ok, the zaurus by default has a usb ipaddr of 192.168.129.201  When I
plug in the zaurus, the usbnet file fires and sets up the usb0 network
device, adds a route to the zaurus via the usb0, turns on ip
forwarding, and modifies the iptables to nat & masquerade through eth1.
--BEGIN--
#!/bin/bash

zIface=usb0
zIfaceIP=192.168.129.1
zIP=192.168.129.201

/sbin/ifconfig $zIface $zIfaceIP netmask 255.255.255.0 up
/sbin/route add -host $zIP $zIface

echo 1 > /proc/sys/net/ipv4/ip_forward
iptables  -t nat -F
iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE
--END--

I do have a device /etc/sysconfig/network-scripts/ifcfg-usb0 that is:
DEVICE=usb0
ONBOOT=no
BOOTPROTO=none
BROADCAST=192.168.129.255
IPADDR=192.168.129.1
NETMASK=255.255.255.0
NETWORK=192.168.129.0
NOZEROCONF=yes
USERCTL=no
PEERDNS=no
TYPE=Unknown
IPV6INIT=no
NOZEROCONF=yes

So it is static, but I get the following in the /var/log/messages:
Oct 14 11:57:26 localhost kernel: usb 3-1: new full speed USB device
using address 9
Oct 14 11:57:27 localhost kernel: usb0: register usbnet at
usb-0000:00:1d.1-1, Sharp Zaurus SL-5x00
Oct 14 11:57:27 localhost kernel: usbcore: registered new driver
usbnet Oct 14 11:57:30 localhost NetworkManager: Error: network
configuration for device 'usb0' was invalid (non-DCHP configuration,
but no address/gateway specificed).  Will use DHCP instead. Oct 14
11:57:30 localhost NetworkManager: SIOCGMIIPHY on usb0 failed:
Operation not supported
Oct 14 11:57:30 localhost NetworkManager:
nm_create_device_and_add_to_list(): adding device 'usb0' (wired)
Oct 14 12:00:56 localhost dhclient: DHCPREQUEST on usb0 to
192.168.129.201 port 67
Oct 14 12:00:59 localhost dhclient: DHCPREQUEST on usb0 to
192.168.129.201 port 67

Ok, after this, I do have an active usb0 device:
 ifconfig usb0
usb0      Link encap:Ethernet  HWaddr 9E:82:D9:6A:7E:C4
          inet addr:192.168.129.1  Bcast:192.168.129.255 
Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:368 (368.0 b)

but no route:
 netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window 
irtt Iface
192.9.200.0     0.0.0.0         255.255.255.0   U         0 0        
 0 eth1
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0        
 0 lo
0.0.0.0         192.9.200.159   0.0.0.0         UG        0 0        
 0 eth1


If I do the following:
 route add -host 192.168.129.201 usb0

the route gets added, then torn down.

So, can I use NetworkManager and still be able to sync my zaurus?
Comment 1 Dan Williams 2004-10-14 16:36:56 EDT
should be fixed in the next release... NetworkManager will only find
and attempt to control 802.3 and 802.11 devices.

Can you paste in the section of the 'lshal' command for the 'usb0' device?
Comment 2 Brian Millett 2004-10-15 08:32:19 EDT
lshal | grep -i usb0
lshal version 0.2.98.cvs20040929
  net.linux.sysfs_path = '/sys/class/net/usb0'  (string)
  net.interface = 'usb0'  (string)
Comment 3 Dan Williams 2004-10-15 09:12:53 EDT
One more quick thing, could you paste in the "info.capabilities"
string from the 'usb0' section?

Thanks!
Dan
Comment 4 Brian Millett 2004-10-15 09:23:33 EDT
How about the whole section :-)
udi =
'/org/freedesktop/Hal/devices/usb_usb_device_4dd_8004_0_-1_noserial_0'
  info.capabilities = 'net net.80203'  (string)
  net.linux.sysfs_path = '/sys/class/net/usb0'  (string)
  net.interface = 'usb0'  (string)
  net.address = '5a:4f:09:15:62:13'  (string)
  net.interface_up = true  (bool)
  net.linux.ifindex = 4  (0x4)  (int)
  net.80203.mac_address = 99295501312531  (0x5a4f09156213)  (uint64)
  net.arp_proto_hw_id = 1  (0x1)  (int)
  net.media = 'Ethernet'  (string)
  info.category = 'net.80203'  (string)
  info.udi =
'/org/freedesktop/Hal/devices/usb_usb_device_4dd_8004_0_-1_noserial_0'
 (string)
  info.product = 'USB Communications Interface'  (string)
  usb.interface.subclass = 6  (0x6)  (int)
  usb.interface.protocol = 0  (0x0)  (int)
  usb.interface.number = 0  (0x0)  (int)
  usb.interface.class = 2  (0x2)  (int)
  usb.configuration_value = 1  (0x1)  (int)
  usb.device_class = 2  (0x2)  (int)
  usb.device_protocol = 0  (0x0)  (int)
  usb.device_subclass = 0  (0x0)  (int)
  usb.max_power = 0  (0x0)  (int)
  usb.num_configurations = 1  (0x1)  (int)
  usb.num_interfaces = 2  (0x2)  (int)
  usb.device_revision_bcd = 0  (0x0)  (int)
  usb.is_self_powered = true  (bool)
  usb.can_wake_up = false  (bool)
  usb.product_id = 32772  (0x8004)  (int)
  usb.vendor_id = 1245  (0x4dd)  (int)
  usb.vendor = 'Sharp Corp.'  (string)
  usb.product = 'Zaurus SL-5000D/SL-5500 PDA'  (string)
  usb.bus_number = 3  (0x3)  (int)
  usb.port_number = 1  (0x1)  (int)
  usb.level_number = 1  (0x1)  (int)
  usb.linux.device_number = 7  (0x7)  (int)
  usb.linux.parent_number = 7  (0x7)  (int)
  usb.num_ports = 0  (0x0)  (int)
  usb.speed_bcd = 4608  (0x1200)  (int)
  usb.version_bcd = 512  (0x200)  (int)
  info.parent =
'/org/freedesktop/Hal/devices/usb_device_4dd_8004_0_-1_noserial'  (string)
  usb.linux.sysfs_path =
'/sys/devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.0'  (string)
  linux.sysfs_path_device =
'/sys/devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.0'  (string)
  linux.sysfs_path =
'/sys/devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.0'  (string)
  info.bus = 'usb'  (string)
Comment 5 Dan Williams 2004-10-22 09:41:43 EDT
should be fixed in current CVS, NM will ignore your device (and
possibly other USB devices that do ethernet unfortunately...)
Comment 6 Brian Millett 2004-11-19 11:13:03 EST
Dan, after yuming to 
NetworkManager-0.3.2-3.cvs20041117
NetworkManager-gnome-0.3.2-3.cvs20041117
I still have the same behavior.  Is there some configuration I am
missing?  It looks like the route is added, but is then torn down.  If
I try to add the route with '/sbin/route add -host 192.168.129.201
usb0' the route gets added, but then gets torn down.
Comment 7 Brian Millett 2005-08-09 13:43:45 EDT
NetworkManager-devel-0.4-34.cvs20050729
NetworkManager-0.4-34.cvs20050729
NetworkManager-gnome-0.4-34.cvs20050729
NetworkManager-glib-0.4-34.cvs20050729


Well Dan, I just tried it again, and it works!!  So this bug is closed.

Note You need to log in before you can comment on or make changes to this bug.