Bug 1357383 - Better Switchable Graphics Support
Summary: Better Switchable Graphics Support
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Changes Tracking
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Hans de Goede
QA Contact:
URL:
Whiteboard: ChangeAcceptedF25, SelfContainedChange
: 1357385 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-18 06:07 UTC by Jan Kurik
Modified: 2016-11-22 13:59 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-22 13:59:09 UTC


Attachments (Terms of Use)

Description Jan Kurik 2016-07-18 06:07:18 UTC
This is a tracking bug for Change: Better Switchable Graphics Support
For more details, see: https://fedoraproject.org//wiki/Changes/BetterSwitchableGraphicsSupport

All modern laptops have a gpu integrated into their processor (the igpu), some models also have a more powerful dedicated gpu (dgpu), this is called switchable graphics. The goal of this feature is to improve Fedora's support for such laptops.

Comment 1 Jan Kurik 2016-07-18 06:19:43 UTC
*** Bug 1357385 has been marked as a duplicate of this bug. ***

Comment 2 Jan Kurik 2016-07-26 04:19:30 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.

Comment 3 Jan Kurik 2016-07-26 05:22:56 UTC
On 2016-July-26, we have reached Fedora 25 Change Checkpoint: Completion deadline (testable).

At this point, all accepted changes should be substantially complete, and testable. Additionally, if a change is to be enabled by default, it must be enabled at Change Completion deadline as well.

Change tracking bug should be set to the MODIFIED state to indicate it achieved completeness.

Incomplete and non testable Changes will be reported to FESCo on 2016-July-29 meeting.

Comment 4 Dingzhong Chen 2016-08-19 09:28:14 UTC
Will this also improve the experience with proprietary drivers from Nvidia or AMD?

Comment 5 Hans de Goede 2016-08-19 10:24:27 UTC
(In reply to Dingzhong Chen from comment #4)
> Will this also improve the experience with proprietary drivers from Nvidia
> or AMD?

No for now we are purely focussing on the experience when using Open Source drivers.

Comment 6 Aynur Yanturin 2016-08-31 07:14:49 UTC
Dear Hans de Goede,
I cannot understand from the description whether this implies changing the gpu automatically for gpu-heavy tasks as in Windows) or manually (as in nvidia-prime or bumblebee). Could you please clarify?

Comment 7 Hans de Goede 2016-08-31 10:02:17 UTC
The focus for now is on just making things work, using the discrete gpu as little as possible. E.g. currently there are sometimes problems using external outputs which are only connected to the dgpu; or problems with suspend / resume. The focus of this feature is to fix all these problems.

Besides that I'm also trying to make sure that "DRI_PRIME=1 opengl-app" works everywhere to actually
run opengl heavy tasks on the dgpu.

Note this is all with the opensource drivers, closed source drivers are not supported by Fedora. Since the nouveau opengl performance is not always what it should be, using "DRI_PRIME=1 opengl-app" there is no necessarily a win.

Comment 8 Jan Kurik 2016-09-29 09:06:19 UTC
On 2016-Sep-27 we reached the "Change Checkpoint: 100% Code Complete Deadline" milestone for Fedora 25 release. At this point all the Changes not at least in "ON_QA" state should be brought to FESCo for review. Please update the state of this bug to "ON_QA" if it is already 100% completed. Please let me know in case you have any trouble with the implementation and the Change needs any help or review.

Thanks, Jan

Comment 9 Didier 2016-10-28 12:48:50 UTC
FYI :

(not quite sure whether to post this as a separate bug, or here, as feedback to the Test Day)


Fairly recent high-end Dell Precision 7710 (latest BIOS 1.8.3 10/2016) :
- LCD : 17.3" UHD 3840x2160
- IGP : Intel Xeon E3-1545M (Intel Iris Pro P580)
- DGP : AMD FirePro W7170M (Radeon R9 285) , GCN 1.2

WRT https://fedoraproject.org/wiki/Test_Day:2016-10-26_BetterSwitchableGraphicsSupport , downloaded and ran Fedora-Workstation-Live-x86_64-25-20161026.n.0.iso (from https://www.happyassassin.net/nightlies.html).


Experiencing the same issues as with almost every F24/kernel incantation :

- With hybrid/switchable graphics enabled :
the system almost always locks up hard (black screen, no caps lock or num lock, no Alt-SysRq) when trying to suspend or when the screen saver (DPMS ?) is started.
This is with both i915 and amdgpu loaded (vgaswitcheroo), and with amdgpu blacklisted.

- With hybrid/switchable graphics disabled in the BIOS :
Screen locking usually works, suspending usually fails.

Other info :
* Tested with and without "dis_ucode_ldr" kernel parameter ;
* Unfortunately, it seems I am unable to setup kernel logging via USB serial console ;
* Willing to supply all kinds of info (ACPI dumps etc.), if instructed what & how.

Comment 10 Hans de Goede 2016-10-28 13:03:07 UTC
Hi,

(In reply to Didier from comment #9)
> Fairly recent high-end Dell Precision 7710 (latest BIOS 1.8.3 10/2016) :
> - LCD : 17.3" UHD 3840x2160
> - IGP : Intel Xeon E3-1545M (Intel Iris Pro P580)
> - DGP : AMD FirePro W7170M (Radeon R9 285) , GCN 1.2

Can you please file a new bug for this (just copy and paste your comment here to a new bug).
Pick xorg-x11-drv-ati as the component; and add me to the Cc.

Can you try hybrid mode with the 4.9 kernel? Download it here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=812344

Download the kernel-core and kernel-modules files for your arch (likely x86_64) into a new directory,
then in that directory run: "sudo rpm -ivh kernel*.rpm". Note with kernels you should always use -ivh and not -Uvh so that they get installed in parallel and you can still choose the old kernel in the bootloader.
Please do not use any special kernel cmdline options when trying the 4.9 kernel.

If the 4.9 kernel does not resolve the suspend/resume issue you are seeing, please try hybrid mode with the amdgpu driver blacklisted; and see if this at least gives you a working system including working suspend / resume ?

Note I'm afraid this is going to be a tricky issue to resolve.

Regards,

Hans

Comment 11 Didier 2016-10-28 18:32:38 UTC
Hi Hans,

Thanks for the reply ; I'll open a new bug report and test Koji's kernel-4.9.x after the weekend.

I guess, without any decent kernel reporting (i.e. by means of USB serial logging), these will be largely shots in the dark.


A similar Dell Precision 7510 exhibits more or less the same issues ; Dell ACPI ?

(how ironic I specifically dropped years of NVIDIA use because of its closed source nature).

Comment 12 starfall 2016-11-01 15:14:09 UTC
After upgrading to kernel 4.8.4-200.fc24, DRI_PRIME is resulting in hangs on my Dell XPS 15 9530 (Nouveau on 750M). It was working fine on 4.7.9-200 (although reclocking never worked on this Keplar card properly, it still ran fine).

Comment 13 Didier 2016-11-02 14:00:25 UTC
(In reply to Hans de Goede from comment #10)

> Can you please file a new bug for this (just copy and paste your comment
> here to a new bug).
> Pick xorg-x11-drv-ati as the component; and add me to the Cc.

Filed as bug 1391045.


Note You need to log in before you can comment on or make changes to this bug.