Bug 1357428 - Tomcat 8.0.32 breaks deploy for candlepin.
Summary: Tomcat 8.0.32 breaks deploy for candlepin.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tomcat
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Coty Sutherland
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-18 08:07 UTC by David Šarman
Modified: 2016-09-01 18:53 UTC (History)
9 users (show)

Fixed In Version: tomcat-8.0.36-2.fc25 tomcat-8.0.36-2.fc24 tomcat-8.0.36-2.fc23
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-01 13:38:05 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Apache Bugzilla 58999 0 None None None 2016-07-18 08:07:12 UTC

Description David Šarman 2016-07-18 08:07:13 UTC
Description of problem:
Tomcat version 8.0.32 contains bug precluding candlepin from successfully deploying.

Version-Release number of selected component (if applicable):
8.0.32-4.fc24

How reproducible:
always

Steps to Reproduce:
1.Try to deploy Candlepin server.

Actual results:
Deploy fails with  StringIndexOutOfBoundsException.

Expected results:
Deploy succeeds.

Additional info:
According to https://bz.apache.org/bugzilla/show_bug.cgi?id=58999#c7 this should be resolved in tomcat 8.0.33.

Comment 1 Filip Nguyen 2016-07-19 06:52:48 UTC
Candlepin is a standard Java application that uses Mozilla Rhino Java scripting engine. Attaching candlepin.war that can be used to reproduce the issue

Comment 3 Coty Sutherland 2016-08-08 20:13:20 UTC
This looks to be resolved by the 8.0.36 update that I pushed to fix https://bugzilla.redhat.com/show_bug.cgi?id=1349469. I'll include it in the upcoming update so that you can test it to verify, but it looks OK to me.

Comment 4 Fedora Update System 2016-08-11 18:49:52 UTC
tomcat-8.0.36-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0a4dccdd23

Comment 5 Fedora Update System 2016-08-11 18:50:35 UTC
tomcat-8.0.36-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2b0c16fd82

Comment 6 Fedora Update System 2016-08-11 18:51:17 UTC
tomcat-8.0.36-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f4a443888b

Comment 7 Fedora Update System 2016-08-12 14:28:08 UTC
tomcat-8.0.36-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f4a443888b

Comment 8 Fedora Update System 2016-08-12 20:52:55 UTC
tomcat-8.0.36-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0a4dccdd23

Comment 9 Fedora Update System 2016-08-12 20:52:58 UTC
tomcat-8.0.36-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2b0c16fd82

Comment 10 Filip Nguyen 2016-08-15 08:45:36 UTC
Works for me on F24! Thanks

Comment 11 Fedora Update System 2016-09-01 13:36:59 UTC
tomcat-8.0.36-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2016-09-01 16:55:36 UTC
tomcat-8.0.36-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2016-09-01 18:53:04 UTC
tomcat-8.0.36-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.