Bug 135749 - ensure all account data entered on the create login screen is populated in RHN
ensure all account data entered on the create login screen is populated in RHN
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn360
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Max Spevack
:
Depends On:
Blocks: 123188 131623
  Show dependency treegraph
 
Reported: 2004-10-14 16:13 EDT by Max Spevack
Modified: 2007-04-18 13:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-22 13:40:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max Spevack 2004-10-14 16:13:12 EDT
Description of problem:
This bug may have to be assigned to someone on the server side --
developer will make that decision.

If you create a new account from within firstboot (and presumably from
within the up2date client as well), the First Name/Last Name
combination that you enter is not uploaded to RHN.  When you login to
RHN with your new account, you see that you are listed as "Valued
Customer" and not "Joe Montana" or whoever you happen to be.

Version-Release number of selected component (if applicable):
1.1.23

How reproducible:
Always

Steps to Reproduce:
1.  See description.
2.
3.
  
Actual results:
Your name is "Valued Customer"

Expected results:
Your name is... your name.

Additional info:
Comment 1 Max Spevack 2004-11-14 14:38:48 EST
We need to ensure that all data is properly uploaded to RHN.
Comment 2 Adrian Likins 2004-11-15 09:46:15 EST
this is up to misa, cc'ing him... The data 
is currently not being populated because that
rpc call was disabled for 360 for some reason.
misa can explain better than I...
Comment 3 Mihai Ibanescu 2004-11-15 18:27:25 EST
Added:
The change is currently in dev:

registration.update_contact_info(username, password, info)

where info is the same hash you used to send with register_product
(i.e.  the keys are 'first_name', 'last_name', 'address1', 'zip',
'contact_phone' etc.

There is a capability registration.update_contact_info to check; if
available, the code is available, otherwise the call should not be
made at all (although it's probably safe to try to use
register_product in that case).
Comment 4 Adrian Likins 2004-11-16 16:10:49 EST
up2date-4.3.62 should have the fix when it is built
Comment 5 Max Spevack 2004-11-18 18:36:01 EST
Verified.
Comment 6 Mihai Ibanescu 2004-11-24 10:16:24 EST
Code moved to QA.
Comment 7 Todd Warner 2005-03-22 13:40:51 EST
Mass move from PROD_READY to CLOSED:CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.