Bug 135777 - apm -s fails
apm -s fails
Status: CLOSED DUPLICATE of bug 130975
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-14 19:32 EDT by Tim Taiwanese Liim
Modified: 2015-01-04 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-18 03:20:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg -s64000 output on T23, right after "apm -s" failed; "acpi=off" (13.14 KB, text/plain)
2004-11-19 01:59 EST, Tim Taiwanese Liim
no flags Details
"dmesg -s 64000" with acpi on. (15.29 KB, text/plain)
2005-01-23 23:35 EST, Tim Taiwanese Liim
no flags Details

  None (edit)
Description Tim Taiwanese Liim 2004-10-14 19:32:51 EDT
Description of problem:
  On my IBM T23, upon boot, this message shows up:
	ACPI: Could not use ECDT
  After boot complete, type in "apm" as root and I
  got this message:
	No APM support in kernel
  With Fedora1, "apm" worked fine on the same T23,
  but whether it used apmd or acpid, I am not sure.

Version-Release number of selected component (if applicable):
  acpid-1.0.3-2

How reproducible:
  always.

Steps to Reproduce:
1. install fc3test3 on IBM T23 notebook.
2. reboot, and 
	ACPI: Could not use ECDT
   shows up.
3. login as root, type in "apm".
  
Actual results:
  - saw the error msg "ACPI: Could not use ECDT"
  - apm not usable

Expected results:
  - no said error msg
  - apm usable.
Comment 1 Tim Taiwanese Liim 2004-10-14 19:36:03 EDT
  Excerpt from system log.  Let me know if you need full log.
	Oct 14 18:27:43 formosa kernel: ACPI: Subsystem revision 20040816
	Oct 14 18:27:43 formosa kernel: ACPI: Found ECDT
	Oct 14 18:27:43 formosa kernel: ACPI: Could not use ECDT
	Oct 14 18:27:43 formosa kernel:     ACPI-0265: *** Error: Region
EmbeddedControl(3) has no handler
	Oct 14 18:27:43 formosa kernel:     ACPI-1133: *** Error: Method
execution failed [\_SB_.PCI0.LPC_.FDC_._INI] (Node 11e5df40), AE_NOT_EXIST
	Oct 14 18:27:43 formosa kernel:     ACPI-0265: *** Error: Region
EmbeddedControl(3) has no handler
	Oct 14 18:27:43 formosa kernel:     ACPI-1133: *** Error: Method
execution failed [\_SB_.PCI0.LPC_.EC__._INI] (Node 11e56560), AE_NOT_EXIST
	Oct 14 18:27:43 formosa kernel:     ACPI-0265: *** Error: Region
EmbeddedControl(3) has no handler
	Oct 14 18:27:43 formosa kernel:     ACPI-1133: *** Error: Method
execution failed [\_SB_.PCI0.LPC_.EC__.BAT0._STA] (Node 11e56c60),
AE_NOT_EXIST
	Oct 14 18:27:43 formosa kernel:     ACPI-0158: *** Error: Method
execution failed [\_SB_.PCI0.LPC_.EC__.BAT0._STA] (Node 11e56c60),
AE_NOT_EXIST
	Oct 14 18:27:43 formosa kernel:     ACPI-0265: *** Error: Region
EmbeddedControl(3) has no handler
	Oct 14 18:27:43 formosa kernel:     ACPI-1133: *** Error: Method
execution failed [\_SB_.PCI0.LPC_.EC__.BAT1._STA] (Node 11e56ae0),
AE_NOT_EXIST
	Oct 14 18:27:43 formosa kernel:     ACPI-0158: *** Error: Method
execution failed [\_SB_.PCI0.LPC_.EC__.BAT1._STA] (Node 11e56ae0),
AE_NOT_EXIST
	Oct 14 18:27:43 formosa kernel:     ACPI-0265: *** Error: Region
EmbeddedControl(3) has no handler
	Oct 14 18:27:43 formosa kernel:     ACPI-1133: *** Error: Method
execution failed [\_SB_.PCI0.LPC_.EC__.BGID] (Node 11e5d1a0), AE_NOT_EXIST
	Oct 14 18:27:43 formosa kernel:     ACPI-1133: *** Error: Method
execution failed [\_SB_.PCI0.LPC_.EC__.BINI] (Node 11e5d1c0), AE_NOT_EXIST
	Oct 14 18:27:43 formosa kernel:     ACPI-1133: *** Error: Method
execution failed [\_SB_.PCI0.LPC_.EC__.BSTA] (Node 11e5d200), AE_NOT_EXIST
	Oct 14 18:27:43 formosa kernel:     ACPI-1133: *** Error: Method
execution failed [\_SB_.PCI0.IDE0.SCND.MSTR._STA] (Node 11e5dfa0),
AE_NOT_EXIST
	Oct 14 18:27:43 formosa kernel:     ACPI-0158: *** Error: Method
execution failed [\_SB_.PCI0.IDE0.SCND.MSTR._STA] (Node 11e5dfa0),
AE_NOT_EXIST
	Oct 14 18:27:43 formosa kernel:     ACPI-0265: *** Error: Region
EmbeddedControl(3) has no handler
	Oct 14 18:27:43 formosa kernel:     ACPI-1133: *** Error: Method
execution failed [\_SB_.PCI0.LPC_.EC__.BGID] (Node 11e5d1a0), AE_NOT_EXIST
	Oct 14 18:27:43 formosa kernel:     ACPI-1133: *** Error: Method
execution failed [\_SB_.PCI0.LPC_.EC__.BINI] (Node 11e5d1c0), AE_NOT_EXIST
	Oct 14 18:27:43 formosa kernel:     ACPI-1133: *** Error: Method
execution failed [\_SB_.PCI0.LPC_.EC__.BSTA] (Node 11e5d200), AE_NOT_EXIST
	Oct 14 18:27:43 formosa kernel:     ACPI-1133: *** Error: Method
execution failed [\_SB_.PCI0.USB0.URTH.UNST._STA] (Node 11e5d6e0),
AE_NOT_EXIST
	Oct 14 18:27:43 formosa kernel:     ACPI-0158: *** Error: Method
execution failed [\_SB_.PCI0.USB0.URTH.UNST._STA] (Node 11e5d6e0),
AE_NOT_EXIST
	Oct 14 18:27:43 formosa kernel:     ACPI-0265: *** Error: Region
EmbeddedControl(3) has no handler
	Oct 14 18:27:43 formosa kernel:     ACPI-1133: *** Error: Method
execution failed [\_SB_.PCI0.LPC_.EC__.BGID] (Node 11e5d1a0), AE_NOT_EXIST
	Oct 14 18:27:43 formosa kernel:     ACPI-1133: *** Error: Method
execution failed [\_SB_.PCI0.LPC_.EC__.BINI] (Node 11e5d1c0), AE_NOT_EXIST
	Oct 14 18:27:43 formosa kernel:     ACPI-1133: *** Error: Method
execution failed [\_SB_.PCI0.LPC_.EC__.BSTA] (Node 11e5d200), AE_NOT_EXIST
	Oct 14 18:27:43 formosa kernel:     ACPI-1133: *** Error: Method
execution failed [\_SB_.NEST._STA] (Node 11e5dde0), AE_NOT_EXIST
	Oct 14 18:27:43 formosa kernel:     ACPI-0158: *** Error: Method
execution failed [\_SB_.NEST._STA] (Node 11e5dde0), AE_NOT_EXIST
	Oct 14 18:27:43 formosa kernel: ACPI: Interpreter enabled
	Oct 14 18:27:43 formosa kernel: ACPI: Using PIC for interrupt routing
	Oct 14 18:27:43 formosa kernel: ACPI: PCI Interrupt Link [LNKA] (IRQs
3 4 5 6 7 9 10 *11)
	Oct 14 18:27:43 formosa kernel: ACPI: PCI Interrupt Link [LNKB] (IRQs
3 4 5 6 7 9 10 *11)
	Oct 14 18:27:43 formosa kernel: ACPI: PCI Interrupt Link [LNKC] (IRQs
3 4 5 6 7 9 10 *11)
	Oct 14 18:27:43 formosa kernel: ACPI: PCI Interrupt Link [LNKD] (IRQs
3 4 5 6 7 9 10 *11)
	Oct 14 18:27:43 formosa kernel: ACPI: PCI Interrupt Link [LNKE] (IRQs
3 4 5 6 7 9 10 *11)
	Oct 14 18:27:43 formosa kernel: ACPI: PCI Interrupt Link [LNKF] (IRQs
3 4 5 6 7 9 10 11) *0, disabled.
	Oct 14 18:27:43 formosa kernel: ACPI: PCI Interrupt Link [LNKG] (IRQs
3 4 5 6 7 9 10 11) *0, disabled.
	Oct 14 18:27:43 formosa kernel: ACPI: PCI Interrupt Link [LNKH] (IRQs
3 4 5 6 7 9 10 11) *0, disabled.
	Oct 14 18:27:43 formosa kernel: ACPI: PCI Root Bridge [PCI0] (00:00)
	Oct 14 18:27:43 formosa kernel: ACPI: Embedded Controller [EC] (gpe 28)
	Oct 14 18:27:43 formosa kernel: ACPI: Power Resource [PUBS] (on)
	Oct 14 18:27:43 formosa kernel: ACPI: PCI Interrupt Link [LNKA]
enabled at IRQ 11
	Oct 14 18:27:43 formosa kernel: ACPI: PCI interrupt 0000:00:1d.0[A]
-> GSI 11 (level, low) -> IRQ 11
	Oct 14 18:27:43 formosa kernel: ACPI: PCI Interrupt Link [LNKD]
enabled at IRQ 11
	Oct 14 18:27:43 formosa kernel: ACPI: PCI interrupt 0000:00:1d.1[B]
-> GSI 11 (level, low) -> IRQ 11
	Oct 14 18:27:43 formosa kernel: ACPI: PCI Interrupt Link [LNKC]
enabled at IRQ 11
	Oct 14 18:27:44 formosa kernel: ACPI: PCI interrupt 0000:00:1d.2[C]
-> GSI 11 (level, low) -> IRQ 11
	Oct 14 18:27:44 formosa kernel: ACPI: PCI interrupt 0000:00:1f.1[A]
-> GSI 11 (level, low) -> IRQ 11
	Oct 14 18:27:44 formosa kernel: ACPI: PCI Interrupt Link [LNKB]
enabled at IRQ 11
	Oct 14 18:27:44 formosa kernel: ACPI: PCI interrupt 0000:00:1f.3[B]
-> GSI 11 (level, low) -> IRQ 11
	Oct 14 18:27:44 formosa kernel: ACPI: PCI interrupt 0000:00:1f.5[B]
-> GSI 11 (level, low) -> IRQ 11
	Oct 14 18:27:44 formosa kernel: ACPI: PCI interrupt 0000:01:00.0[A]
-> GSI 11 (level, low) -> IRQ 11
	Oct 14 18:27:44 formosa kernel: ACPI: PCI interrupt 0000:02:00.0[A]
-> GSI 11 (level, low) -> IRQ 11
	Oct 14 18:27:44 formosa kernel: ACPI: PCI interrupt 0000:02:00.1[B]
-> GSI 11 (level, low) -> IRQ 11
	Oct 14 18:27:44 formosa kernel: ACPI: PCI interrupt 0000:02:02.0[A]
-> GSI 11 (level, low) -> IRQ 11
	Oct 14 18:27:44 formosa kernel: ACPI: PCI Interrupt Link [LNKE]
enabled at IRQ 11
	Oct 14 18:27:44 formosa kernel: ACPI: PCI interrupt 0000:02:08.0[A]
-> GSI 11 (level, low) -> IRQ 11
	Oct 14 18:27:44 formosa kernel: IBM machine detected. Enabling
interrupts during APM calls.
	Oct 14 18:27:44 formosa kernel: apm: BIOS version 1.2 Flags 0x03
(Driver version 1.16ac)
	Oct 14 18:27:44 formosa kernel: apm: overridden by ACPI.
	Oct 14 18:27:44 formosa kernel: ACPI: Processor [CPU] (supports C1 C2 C3)
	Oct 14 18:27:44 formosa kernel: ACPI: Thermal Zone [THM0] (54 C)
	Oct 14 18:27:45 formosa kernel: ACPI: PCI interrupt 0000:00:1f.1[A]
-> GSI 11 (level, low) -> IRQ 11
	Oct 14 18:27:45 formosa kernel: ACPI: (supports S0 S3 S4 S5)
	Oct 14 18:27:45 formosa kernel: ACPI wakeup devices: 
	Oct 14 18:27:45 formosa kernel:  LID SLPB PCI0 UART PCI1 USB0 USB1
USB2 AC97 
	Oct 14 18:27:45 formosa kernel: ACPI: PCI interrupt 0000:02:08.0[A]
-> GSI 11 (level, low) -> IRQ 11
	Oct 14 18:27:45 formosa kernel: ACPI: PCI interrupt 0000:00:1f.5[B]
-> GSI 11 (level, low) -> IRQ 11
	Oct 14 18:27:46 formosa kernel: ACPI: PCI interrupt 0000:00:1d.0[A]
-> GSI 11 (level, low) -> IRQ 11
	Oct 14 18:27:46 formosa kernel: ACPI: PCI interrupt 0000:00:1d.1[B]
-> GSI 11 (level, low) -> IRQ 11
	Oct 14 18:27:46 formosa kernel: ACPI: PCI interrupt 0000:00:1d.2[C]
-> GSI 11 (level, low) -> IRQ 11
	Oct 14 18:27:46 formosa kernel: ACPI: PCI interrupt 0000:02:00.0[A]
-> GSI 11 (level, low) -> IRQ 11
	Oct 14 18:27:46 formosa kernel: ACPI: PCI interrupt 0000:02:00.1[B]
-> GSI 11 (level, low) -> IRQ 11
	Oct 14 18:27:46 formosa kernel: ACPI: AC Adapter [AC] (on-line)
	Oct 14 18:27:46 formosa kernel: ACPI: Battery Slot [BAT0] (battery
present)
	Oct 14 18:27:46 formosa kernel: ACPI: Power Button (FF) [PWRF]
	Oct 14 18:27:46 formosa kernel: ACPI: Lid Switch [LID]
	Oct 14 18:27:46 formosa kernel: ACPI: Sleep Button (CM) [SLPB]
	Oct 14 18:27:48 formosa acpid: acpid startup succeeded
Comment 2 Dave Jones 2004-10-27 01:26:33 EDT
any improvement in the current rawhide kernel ?
Comment 3 Tim Taiwanese Liim 2004-10-27 19:01:48 EDT
No, no luck.  Still see the same
    ACPI: Could not use ECDT
during boot.

Revision tested:
    apmd-3.0.2-24
    kernel-2.6.9-1.643
Let me know if you need more logs/info.
Comment 4 Len Brown 2004-11-18 00:47:48 EST
For APM to work, you need to boot with "acpi=off".

ACPI: Found ECDT
ACPI: Could not use ECDT
ACPI-0265: *** Error: Region EmbeddedControl(3) has no handler

Please verify that you are running the latest BIOS, then
please test the patch here:

http://bugme.osdl.org/show_bug.cgi?id=1690

yes, the complete output of dmesg -s64000 as an attachment
is preferable to excerpts.
Comment 5 Tim Taiwanese Liim 2004-11-19 01:55:29 EST
After updating T23 BIOS from
    1.10  1AET53WW    3/7/2002
to
    1.18  1AET62WW    7/6/2004
this message
    ACPI: Could not use ECDT
no longer shows up during boot if I don't have "acpi=off".  Also
with BIOS 1.18 "poweroff" shuts down power properly, unlike the
1.10 BIOS, where the power remained on at end of "poweroff".  So
upgrading BIOS to 1.18 does help in this aspect.

With "acpi=off" and BIOS 1.18, the same symptom persists:
  - "apm -s" with AC power off brings T23 to standby properly;
    the "moon" LED lits (correct behavior).
  - "apm -s" with AC power on  does NOT bring T23 to standby;
    the "moon" LED does not lit (wrong behavior).

I'll attach "dmesg -s64000" output.

The patch
    http://bugme.osdl.org/show_bug.cgi?id=1690
seems very much related, but it will be a while before I can
apply it and test the results.
Comment 6 Tim Taiwanese Liim 2004-11-19 01:59:47 EST
Created attachment 107036 [details]
dmesg -s64000 output on T23, right after "apm -s" failed; "acpi=off"

This dmesg is from "acpi=off"; let me know if one with acpi on is needed.
Comment 7 Len Brown 2004-11-30 00:22:41 EST
Thank you for confirming that the ACPI mode issues
went away after upgrading to the latest BIOS.

Yes, it would be good to attach the full dmesg
from a boot without any special kernel parameters (ACPI enabled)
to make sure the other warnings in your original post
went away.  No, you don't have to test the 1690 patch
if your ACPI issues have gone away.

I can't help you with the APM issues, but since the ACPI-mode
issues appear to be gone, i'm chaning the summary to reflect
that this is now an APM bug.

Comment 8 Tim Taiwanese Liim 2005-01-23 01:42:23 EST
Once the msg "Could not use ECDT" is gone, my concern then became 
the one in 
    [Bug 130975] apm suspend on ThinkPad X24 with AC power hangs.
where "apm -s" does _not_ work as it did in Fedora 1 and before.
I will send out the dmesg you mentioned earlier, and then close
this issue with reference to 130975 if you agree.
Comment 9 Tim Taiwanese Liim 2005-01-23 23:35:22 EST
Created attachment 110113 [details]
"dmesg -s 64000" with acpi on.

Attached please find output of "dmesg -s 64000" right after reboot,
with ACPI turned on; here is the line in grub.conf:
    kernel /vmlinuz-2.6.10-1.741_FC3 ro root=/dev/VolGroup00/LogVol01 rhgb
quiet
The kernel is 
    Linux formosa 2.6.10-1.741_FC3 #1 Thu Jan 13 16:38:22 EST 2005 i686 i686
i386 GNU/Linux
Comment 10 Tim Taiwanese Liim 2005-01-27 23:19:25 EST

*** This bug has been marked as a duplicate of 130975 ***

Note You need to log in before you can comment on or make changes to this bug.