This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 135795 - mediacheck failed on FC3T3 discs except disc1
mediacheck failed on FC3T3 discs except disc1
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-14 22:34 EDT by Jim Cornette
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 20:35:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jim Cornette 2004-10-14 22:34:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041012

Description of problem:
When FC3T3 was released on Oct 11, I burned the discs using
nautilus-cd-burner. The discs burned without displaying any errors to
the user.
After  medicheck was performed on the discs at the disc 1 mediacheck,
disc 1 passed. All of the other 4 discs failed mediacheck.
I then tried to burn the discs that failed mediacheck using another
drive (DVD burner) at a slower speed (2X). The results were the same.
All discs failed the mediacheck.
The downloaded images all passed md5sum MD5SUM -c.
Since the discs seemed to be the same with both sets of discs, I tried
these discs on a clean install on a test computer and the installation
was successful. I then became confident to upgrade another computer.
The second computer upgraded with no errors. When upgrading the
computer that burned I burned the discs on, I encountered an error
with disc 3. (burned at 2X on DVD burner.) I then pulled the first
disc that was burned on the same CDROM writer used for the install and
passed the error contained on the DVD-RW drive.

Version-Release number of selected component (if applicable):
nautilus-cd-burner-2.8.3-2

How reproducible:
Always

Steps to Reproduce:
1. download iso files, verify integrity of images. 
2. Open nautilus and navigate to image files.
3. right click on highlighted iso image and select "write to CD"
4. boot from disc 1 and mediacheck all burned CDs.
    

Actual Results:  1. images reported OK against MD5SUM from mirror,
downloaded to local drive.
2. no problem navigating to image files.
3. operations seemed normal
4. disc 1 passed mediacheck. disc2,3,4 and the rescue CD failed the
media test.

Expected Results:  All burned CDs to pass the mediacheck.

Additional info:

There are various comments during discussions on the fedora-test-list.
this error happened to another user with the same symptoms. I am not
sure if the other user with the problem used nautilus-cd-burner or
another program.
Suggestions ranged from adding the -dao option to cdrecord, loading
the ide-scsi driver and adding at least 150kb of padding to discs.
These discs were said to pass mediacheck on scsi discs by the other
user with the similar failure.
Also, this failure was with the latest develpment upgrades applied on
Oct 11. The newer version after discovering this failure is dated oct
12. I have not tried burning discs with nautilus-cd-burner-2.8.3-5 to
see if the failure is still present or has been corrected. (latest
version in development)
Comment 1 Alexander Larsson 2004-10-15 04:00:15 EDT
nautilus-cd-burner just uses cdrecord. Do you get the same problem
when you burn a disk using cdrecord?
Comment 2 Harald Hoyer 2004-10-15 05:39:01 EDT
alexl, do you pass the -dao option to cdrecord?
Comment 3 Ross Ridler 2004-10-15 10:48:05 EDT
I have also had the same issue with CD's 2,3 & 4 of FC3T3. They were 
burned from a Sony Desktop PCV-RX755 running Windows XP, using Nero 
6.3.1.6.  I have redownloaded the iso images from other mirrored 
sites with the same results, not passing media check.
rridler@fuse.net
Comment 4 Alexander Larsson 2004-10-15 12:38:27 EDT
harald: No, we don't.
Comment 5 Ben Smith 2004-10-23 08:13:14 EDT
I have this problem burning fc3t2 discs with k3b in fc1.  Mediacheck 
consistently fails on disc 1 and disc 4, but the cds pass md5sum 
checks. 
Comment 6 Greg Douglas 2004-11-12 06:37:24 EST
I encountered the same problem with my upgrade.  I created the CDs in
FC2 using the latest kernel (2.6.8) with the latest version of
cdrecord.  I used the command cdrecord -v -eject speed=0 dev=ATA:1,0,0
file.iso.

Disk one passed, disks 2, 3 and 4 failed.  Manually inspected the
other CDs and all looked well.  Upgrade to FC3 went fine using all 4 CDs. 

I have an LG 52x32x52x burner.
Comment 7 Juan C Nuno 2004-11-12 22:24:57 EST
Hey Greg,

I think the key is the -dao argument.  Here's the command I used:

cdrecord -v -dao -eject speed=16 dev=ATA:1,0,0 -pad <iso>

Like you, I was on Core 2 and my burns of the Core 3 ISOs kept failing
the media check (expect for disk 1).  With that command all my CDs
passed the check and I'm on a fresh installation of Core 3 as I write
this.

Hope this helps.  I was tearing my hair out getting this to work.
Comment 8 Need Real Name 2004-11-17 10:36:15 EST
I also couldn't get disks 2 and 3 of Fedora Core 3 to pass the media
check. Burning the cd's on RedHat 7.3, Fedora Core 2 with different
writers and only passing the -pad all didn't help. Adding the -dao
option (didn't test without -pad) to cdrecord helped my out.

Another solution was to start the installation with "linux ide=nodma"

See also:

http://www.troubleshooters.com/linux/coasterless.htm
http://fedoraforum.org/forum/showthread.php?p=125511#post125511
Comment 9 Jim Cornette 2004-11-29 18:52:58 EST
Since the problem is triggered by an underdeveloped portion of the
kernel, the component has been changed to the kernel. The easiest
solution to get the discs to verify is to add linux ide=nodma and test
the discs. Rebooting and installing with these discs works for
installation.
Would this be an anaconda bug? Maybe dma mode for the cd readers can
be disabled for the mediacheck and then dma re-enabled for the
installation. The long haul solution would be to fix ide-cd.
Comment 10 joram 2005-01-13 14:52:02 EST
ide=nodma worked for my laptop upgrade from RH9 to FC3.  Used xcdroast
to burn cds.  all disks passed medicheck.
Comment 11 Dave Jones 2005-07-15 14:09:10 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 12 Dave Jones 2005-10-02 20:35:56 EDT
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.
Comment 13 Jim Cornette 2005-10-03 20:31:19 EDT
I have only tried the mediacheck with the ide=nodma option since this problem.
Closing the bug is OK

Note You need to log in before you can comment on or make changes to this bug.