Bug 135872 - Internal Compiler Error
Summary: Internal Compiler Error
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc34
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-15 15:35 UTC by Jonathan Zdziarski
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2004-10-18 23:34:32 UTC


Attachments (Terms of Use)
Preprocessed source (199.29 KB, application/fubar-shot-to-hell)
2004-10-16 16:45 UTC, Jonathan Zdziarski
no flags Details

Description Jonathan Zdziarski 2004-10-15 15:35:14 UTC
Description of problem:

When trying to compile the S3TC compression library from
http://homepage.hispeed.ch/rscheidegger/dri_experimental/libtxc_dxtn040623.tar.gz

I receive:

[root@localhost libtxc_dxtn]# make
gcc -c -O3 -Wall -pedantic -fPIC -o txc_compress_dxtn.o
txc_compress_dxtn.c
txc_compress_dxtn.c: In function `encodedxtcolorblockfaster':
txc_compress_dxtn.c:401: internal compiler error: in output_151, at
insn-output.c:1495
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/cc2Ax22k.out file, please attach
this to your bugreport.
make: *** [txc_compress_dxtn.o] Error 1


Version-Release number of selected component (if applicable):

Reading specs from /usr/lib/gcc/i386-redhat-linux/3.4.2/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man
--infodir=/usr/share/info --enable-shared --enable-threads=posix
--disable-checking --with-system-zlib --enable-__cxa_atexit
--disable-libunwind-exceptions --enable-java-awt=gtk
--host=i386-redhat-linux
Thread model: posix
gcc version 3.4.2 20041006 (Red Hat 3.4.2-5)


How reproducible:

very

Steps to Reproduce:
1.Download and extract archive
2.Run 'make'
3.Cry
  
Actual results:

Internal compiler error

Expected results:

Clean build

Additional info:

I'm not wearing any underpants

Comment 1 Jonathan Zdziarski 2004-10-15 16:53:02 UTC
Apperas to be related to the -O3 flag. Can't reproduce this with
sample pieces of code, so it's something specific to what the
compiler's doing with this code.

Comment 2 Jakub Jelinek 2004-10-16 15:56:18 UTC
Preprocessed source stored into /tmp/cc2Ax22k.out file, please attach
this to your bugreport.

Comment 3 Jonathan Zdziarski 2004-10-16 16:45:54 UTC
Created attachment 105324 [details]
Preprocessed source

Comment 4 Jakub Jelinek 2004-10-18 13:15:07 UTC
http://gcc.gnu.org/ml/gcc-patches/2004-10/msg01469.html
Will be fixed in gcc-3.4.2-6.


Note You need to log in before you can comment on or make changes to this bug.