Bug 135880 - Sound not configured at boot - have to use soundcard detection
Sound not configured at boot - have to use soundcard detection
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: sndconfig (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-15 12:18 EDT by Bob Gustafson
Modified: 2014-03-16 22:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-19 11:39:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2004-10-15 12:18:54 EDT
Description of problem:

I have to go to 'System settings'->'Soundcard Detection' and click
there before I get sound.

Version-Release number of selected component (if applicable):

I have a 'fresh' fc3test3 loaded from cdroms and then 'yum update' ed
to current status (as of this morning (2.6.8-1.624smp).

How reproducible:

  Have booted a couple of times - need to do soundcard detection each
time.

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:

  see above

Expected results:

  Maybe need to do the Soundcard Detection once, then it sticks
through subsequent boots.

Additional info:

I have it configured to come up in command line, then go to X with
'startx'.
Comment 1 Bill Nottingham 2004-10-15 12:22:45 EDT
Is it just muted, or is the module not loaded at all?
Comment 2 Bob Gustafson 2004-10-15 16:00:41 EDT
It is not muted, at least looking at the volume control icon (sound
waves) and control (3/4 up) and preferences (mute not checked).

When I do the 'Soundcard Detection' nothing much changes, except that
I can hear sound.

Is it loaded?

Reboot

  [root@hoho2 user1]# /sbin/lsmod > lsmodboot.out

Soundcard Detection

[  root@hoho2 user1]# /sbin/lsmod > lsmodtweek.out

[root@hoho2 user1]# diff lsmodboot.out lsmodtweek.out
[root@hoho2 user1]#

Looks like there is no difference there either - same modules loaded
before and after 'Soundcard Detection'.

Maybe some state on disk is not set - and gnome control doesn't see it
(or look here).
Comment 3 Bill Nottingham 2004-10-15 16:09:12 EDT
Odd. What happens if you upgrade to current devel packages?
Comment 4 Bob Gustafson 2004-10-15 18:08:16 EDT
I think I am there already

[root@hoho2 user1]# yum update
Setting up Update Process
Setting up Repo:  development
repomd.xml                100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
developmen: ################################################## 3433/3433
No Packages marked for Update/Obsoletion
[root@hoho2 user1]#
[root@hoho2 user1]# cat /proc/version
Linux version 2.6.8-1.624smp (bhcompile@tweety.build.redhat.com) (gcc
version 3.4.2 20041006 (Red Hat 3.4.2-5)) #1 SMP Thu Oct 14 21:16:29
EDT 2004
[root@hoho2 user1]#
Comment 5 Bill Nottingham 2004-10-15 18:14:34 EDT
If you run 'alsactl restore', does that work (instead of the soundcard
detection)
Comment 6 Bob Gustafson 2004-10-19 11:39:48 EDT
After yum was fixed, I updated and rebooted this morning and the
soundcard problem went away. Did not have a chance to run alsactl
restore before this process.

Works for me

Note You need to log in before you can comment on or make changes to this bug.