Bug 135963 - yum gives undefined symbol xmlSchemaSetValidOptions
yum gives undefined symbol xmlSchemaSetValidOptions
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-15 18:16 EDT by Dave Higgins
Modified: 2014-01-21 17:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-16 10:28:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Higgins 2004-10-15 18:16:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a4)
Gecko/20040927

Description of problem:
Trying to run both yum or up2date I get the following ImportError:

yum
Traceback (most recent call last):
  File "/usr/share/yum-cli/yummain.py", line 23, in ?
    import yum
  File "/usr/lib/python2.3/site-packages/yum/__init__.py", line 32, in ?
    import groups
  File "/usr/lib/python2.3/site-packages/yum/groups.py", line 3, in ?
    import comps
  File "/usr/lib/python2.3/site-packages/yum/comps.py", line 5, in ?
    import libxml2
  File "/usr/lib64/python2.3/site-packages/libxml2.py", line 1, in ?
    import libxml2mod
ImportError: /usr/lib64/python2.3/site-packages/libxml2mod.so:
undefined symbol: xmlSchemaSetValidOptions

up2date
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 34, in ?
    from up2date_client import up2date
  File "/usr/share/rhn/up2date_client/up2date.py", line 36, in ?
    import depSolver
  File "/usr/share/rhn/up2date_client/depSolver.py", line 4, in ?
    import packageList
  File "/usr/share/rhn/up2date_client/packageList.py", line 17, in ?
    import up2dateComps
  File "/usr/share/rhn/up2date_client/up2dateComps.py", line 7, in ?
    from rhpl import comps
  File "/usr/lib64/python2.3/site-packages/rhpl/comps.py", line 5, in ?
    import libxml2
  File "/usr/lib64/python2.3/site-packages/libxml2.py", line 1, in ?
    import libxml2mod
ImportError: /usr/lib64/python2.3/site-packages/libxml2mod.so:
undefined symbol: xmlSchemaSetValidOptions



Version-Release number of selected component (if applicable):
yum-2.1.7-2, libxml2-2.6.14-1, libxml2-2.6.13-1, up2date-4.3.40-1

How reproducible:
Always

Steps to Reproduce:
1.yum <Press Enter>
2.
3.up2date <Press Enter>
    

Actual Results:  yum
Traceback (most recent call last):
  File "/usr/share/yum-cli/yummain.py", line 23, in ?
    import yum
  File "/usr/lib/python2.3/site-packages/yum/__init__.py", line 32, in ?
    import groups
  File "/usr/lib/python2.3/site-packages/yum/groups.py", line 3, in ?
    import comps
  File "/usr/lib/python2.3/site-packages/yum/comps.py", line 5, in ?
    import libxml2
  File "/usr/lib64/python2.3/site-packages/libxml2.py", line 1, in ?
    import libxml2mod
ImportError: /usr/lib64/python2.3/site-packages/libxml2mod.so:
undefined symbol: xmlSchemaSetValidOptions

up2date
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 34, in ?
    from up2date_client import up2date
  File "/usr/share/rhn/up2date_client/up2date.py", line 36, in ?
    import depSolver
  File "/usr/share/rhn/up2date_client/depSolver.py", line 4, in ?
    import packageList
  File "/usr/share/rhn/up2date_client/packageList.py", line 17, in ?
    import up2dateComps
  File "/usr/share/rhn/up2date_client/up2dateComps.py", line 7, in ?
    from rhpl import comps
  File "/usr/lib64/python2.3/site-packages/rhpl/comps.py", line 5, in ?
    import libxml2
  File "/usr/lib64/python2.3/site-packages/libxml2.py", line 1, in ?
    import libxml2mod
ImportError: /usr/lib64/python2.3/site-packages/libxml2mod.so:
undefined symbol: xmlSchemaSetValidOptions

Expected Results:  updates

Additional info:
Comment 1 Seth Vidal 2004-10-16 02:27:37 EDT
You've got a broken package or a broken dependency somewhere.

try:
 rpm -Va --nofiles --nomd5

And see if it reports any dependency problems.

And/or try:
rpm -V libxml2-python libxml2

see if any files show up as modified.

Note You need to log in before you can comment on or make changes to this bug.